Bug 34177 - [TTV] Can't seem to start editing an editable cell from the keyboard
[TTV] Can't seem to start editing an editable cell from the keyboard
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
All All
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
: FOCUS
Depends on: 31896
Blocks: 33281
  Show dependency treegraph
 
Reported: 2003-06-04 19:53 UTC by David-john Burrowes
Modified: 2008-12-22 18:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David-john Burrowes 2003-06-04 19:53:01 UTC
When the keyboard focus is in an editable cell,
there doesn't appear to be a way to start editing
the contents of the cell.  (in contrast, it is
possible to do this in the property sheet).

To reproduce: display the Local Variables view,
and move the keyboard focus to the Value column. 
How to edit this?
Comment 1 Jiri Rechtacek 2003-06-04 22:41:17 UTC
This issue blocks the umbrella issue 33281 - TreeTableView improving. All TTV's
issues should be fixed separately at once on base UI spec (task 31621).
Comment 2 Jiri Rechtacek 2003-06-05 11:14:06 UTC

*** This issue has been marked as a duplicate of 19226 ***
Comment 3 Marian Mirilovic 2003-07-23 16:04:40 UTC
Jirka, in my opinion this isn't duplicate of issue 19226 -> reopen.
Comment 4 _ tboudreau 2003-11-22 23:07:03 UTC
Fixed in property panel rewrite branch - you can now press space to
edit either the current cell (if not read only) or the nearest
read-write cell to the left of the current cell (excluding the node name).
Comment 5 _ tboudreau 2003-12-09 09:37:16 UTC
Property panel rewrite branch merged.
Comment 6 Marian Mirilovic 2005-07-13 13:24:58 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo