Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 34151 - Scrollbar moves when any boolean value is changed in the PS
Scrollbar moves when any boolean value is changed in the PS
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows ME/2000
: P3 (vote)
: TBD
Assigned To: _ tboudreau
issues@platform
:
Depends on:
Blocks: 33815
  Show dependency treegraph
 
Reported: 2003-06-04 15:00 UTC by dpavlica
Modified: 2008-12-22 17:42 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dpavlica 2003-06-04 15:00:05 UTC
When user changes any boolean value, then ScrollBar moves 
suddenly up or down without any reason. It's disturbing a 
bit.
Comment 1 _ tboudreau 2003-06-04 17:42:37 UTC
I'll see what I can do.  Probably it's some default behavior wired
into JScrollPane - noticing when child components are added or
something.  Probably it notices a component was added and assumes
it out to make sure it's visible, and tries to scroll it into view.

Hopefully it won't be too hard to find and disable.
Comment 2 _ tboudreau 2003-06-24 10:28:26 UTC
I can't reproduce this in the current build.  Note that
the scrollbar *will* move if you click any property that
it is partially hidden by the bottom edge of the property
sheet.  This is the default behavior of JTable, and
scrolling a half-displayed value into view seems completely
reasonable to me.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo