Bug 33993 - focus lost on navigating explorer nodes
focus lost on navigating explorer nodes
Status: CLOSED DUPLICATE of bug 32909
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows 95/98
: P3 (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-29 00:59 UTC by bht
Modified: 2008-12-22 16:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2003-05-29 00:59:58 UTC
Product Version       = NetBeans IDE 3.5 RC2
(Build 200305182350)
IDE Versioning        = IDE/1 spec=3.42.1
impl=200305182350
Operating System      = Windows 98 version 4.10
running on x86
Java; VM; Vendor      = 1.4.1; Java HotSpot(TM)
Client VM 1.4.1-b21; Sun Microsystems Inc.


The explorer has a nice navigation feature that
works like code completion but it is somewhat broken.

How to reproduce:
Using your cursor up and down keys to navigate an
explorer tree.

Type a letter and the focus is on the first node
whose name begins with that letter. A small
textfield at the top records your typing.

Then press [Esc] so your cursor leaves that text
field and can use your cursor keys to continue
navigating.

Expected behavior:

You should be able to navigate the tree as before
typing letters.

Actual behavior:

The vertical scrollbar moves and you have to
re-focus with either [Shift+Tab] or the mouse to
get back to where you were before.
Comment 1 pzajac 2003-05-29 09:21:52 UTC
reassigned to openide explorer
Comment 2 Jiri Rechtacek 2003-05-29 11:48:49 UTC
It's a duplicate of issue 32909, fixed in nb40 dev.

*** This issue has been marked as a duplicate of 32909 ***
Comment 3 Lukas Hasik 2003-06-11 16:01:35 UTC
x


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo