Bug 33665 - ant-docs.nbm from 3.5 stable AU is broken - missing netbeans/docs/ant-api.zip
ant-docs.nbm from 3.5 stable AU is broken - missing netbeans/docs/ant-api.zip
Status: VERIFIED FIXED
Product: usersguide
Classification: Unclassified
Component: Ant
3.x
PC Linux
: P1 (vote)
: 3.x
Assigned To: rnovak
issues@projects
:
Depends on:
Blocks: 33098
  Show dependency treegraph
 
Reported: 2003-05-15 19:10 UTC by Jesse Glick
Modified: 2005-07-15 07:49 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-05-15 19:10:25 UTC
Just download "Ant 1.5.1 Documentation" from 3.5
stable AU. You get errors like:

Annotation: Resource "docs/ant-api.zip" could not
be found and will not be mounted.
org.xml.sax.SAXException: Mount resource not found
	at
org.netbeans.modules.javadoc.search.environment.JavadocProcessor.throwIllegalMountException(JavadocProcessor.java:135)

and the Javadoc is not available (though the Ant
manual and code completion are there I think).

Confirmed that

http://www.netbeans.org/download/nbms/35/stable/Development_Tools/ant-docs.nbm

is simply broken and fails to include the entry

netbeans/docs/ant-api.zip

for some reason. By comparison, the alpha NBM

http://www.netbeans.org/download/nbms/alpha/release35/ant-docs.nbm

(which claims to be the same 2.11.1 version) does
include this entry and is OK as far as I know.
Apparently whoever built the "stable" NBM
corrupted it somehow, or perhaps it was built
before some bugfix was made in the build script?

It is not acceptable for an NBM on the stable
update center to be visibly broken like this,
hence the P1.
Comment 1 David Konecny 2003-05-16 12:43:14 UTC
On 17.1.2003 I fixed issue 29871 ("there is no way to distinguish Ant
1.4.1 and Ant 1.5 documentation modules on AU") and sent two NBMs to
RobertN to upload them on stable AU. At that time for NB34x. Both
these versions contained correct "netbeans\doc\ant-api.zip".

Robert, I'm assigning this issue to you. Let me know if something is
needed.
Comment 2 rnovak 2003-05-16 19:00:43 UTC
I will update module NBM with working version.
Comment 3 David Konecny 2003-05-21 09:31:33 UTC
What is the progress of this issue? It is P1.
Comment 4 rnovak 2003-05-21 12:43:21 UTC
Corrcet NBM for NB 3.5 was uploaded to stable UC. David, didn't you
receive my mail?
Comment 5 David Konecny 2003-05-21 12:47:07 UTC
No.
Comment 6 Jesse Glick 2003-05-21 15:26:48 UTC
Fixed for the 3.5 stable AU, correct? Please set target milestone to a
non-TBD value whenever an issue is marked FIXED.
Comment 7 Marian Mirilovic 2005-07-15 07:49:55 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo