Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 33641 - [TTV]The Ctrl-C (Copy) and Ctrl-V(Paste) not working in Options Window
[TTV]The Ctrl-C (Copy) and Ctrl-V(Paste) not working in Options Window
Status: CLOSED WORKSFORME
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
All All
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-15 14:11 UTC by Jan Lahoda
Modified: 2008-12-23 11:06 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2003-05-15 14:11:35 UTC
Nevada, RC3, JDK1.4.1_02, MDI.
Steps to reproduce:
1. Start the IDE with the clean userdir
2. Open Options window (Tools/Options)
3. Select node Debugging and Execution/Debugger
Types/Default Debugging
4. Press Ctrl-C
5. Select node Debugging and Execution/Debugger Types
6. Press Ctrl-V (Paste/Copy)
7. A new debugging type with name Default
Debugging_1 should be created, but it is not.

Further investigation shows that neither of these
actions work.
On the other hand, Delete (Del) action works OK.

This problem does occur with other nodes in the
Options window as well, so I suppose it is not
problem of the particular debugger type.

The actions work OK when invoked from the context
menu.
Comment 1 Petr Hrebejk 2003-05-15 16:57:22 UTC
Adding Peter to CC. I know he did something with actions last days. 
Could it be related?
Comment 2 Peter Zavadsky 2003-05-15 17:49:29 UTC
Well, it could be, I don't know now, I'll look at it closer.
Comment 3 Peter Zavadsky 2003-05-15 18:20:32 UTC
Problem seem to be following. (Put debug messages into
TopComponent.processKeyBinding)

In global keymap there is mapped the action to keystroke Ctrl C
(pressed), but there comes into that method, only Ctrl C (released)
keystroke, so the CopyAction isn't found, thus no action performed.

I didn't look at it why it is so. Just you to know.
Comment 4 Petr Hrebejk 2003-05-23 11:31:15 UTC
Probably a bug in TreeTableView?
Comment 5 Stanislav Aubrecht 2005-01-12 14:37:53 UTC
it seems to be working fine in the latest trunk build
(i tried copying & pasting toobar item nodes in the options window)
Comment 6 Marian Mirilovic 2006-01-17 14:35:36 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo