Bug 33458 - [SDI] Focus does not come back to the Explorer window
[SDI] Focus does not come back to the Explorer window
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows ME/2000
: P3 (vote)
: TBD
Assigned To: David Simonek
issues@platform
: A11Y, FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-07 10:13 UTC by ccv
Modified: 2008-12-23 10:54 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ccv 2003-05-07 10:13:28 UTC
Steps to reproduce:

- select some directory in the Explorer window
- create J2EE/EJBModule from wizard and select its
node in the Explorer
- call popup menu via Shift+F10
- select, for example, "add EJB" menu item from
context menu
- push Escape in the "Add EJB" dialog
- dialog closed and focus is in the Main window   

Focus should come back to the Explorer window.
This bug exists for windows platform only.

Product Version  = Sun ONE Studio 5, Standard
Edition (Build 030502)
IDE Versioning = IDE/1 spec=3.42.1 impl=030502
Operating System = Windows 2000 version 5.0
running on x86
Java; VM; Vendor = 1.4.1_02; Java HotSpot(TM)
Client VM 1.4.1_02-b06; Sun Microsystems Inc
Comment 1 mslama 2003-05-13 14:40:59 UTC
Yes. On Linux it works fine. Need to investigate. Marian please can
you test with latest JDK?
Comment 2 Marian Mirilovic 2003-05-13 16:19:48 UTC
I am sorry but it works for me. 

Win2000, jdk 1.4.1_02 and 1.4.2(build 22)

ccv:
What windowing mode you use? Do you have something like "focus follow
mouse" switch on ? 
Comment 3 ccv 2003-05-14 05:46:37 UTC
The problem is 100% reproducable in the SDI mode, I am using "Click in
window to make active" style.

It works fine in MDI mode.
Comment 4 mslama 2003-05-14 08:24:01 UTC
Yes SDI/MDI is very important info for most of winsys bugs. We will
check again.
Comment 5 Marian Mirilovic 2003-05-14 09:20:37 UTC
It really doesn't work in SDI - Win2000, IMHO it works fine on SOl8:)
Comment 6 Marian Mirilovic 2003-11-26 12:58:04 UTC
Because Window System v1 will not be supported from now by our team, all old
winsys issues (now "core/window system v1" issues) are going to be closed as
WONTFIX. 

Changes in API which emerged both from UI spec 
and problems with adjusting to the older API are described in the document
http://core.netbeans.org/windowsystem/changes.html.
 It shows also recommends how the client code should be adjusted to the new
window system.

If you think this issue apply also to the new winsys then change the
subcomponent (to "core/window system") and REOPEN it.
Comment 7 ccv 2003-11-27 05:11:48 UTC
It is important accessibility issue for windows platform. 
Comment 8 Peter Zavadsky 2003-11-27 12:45:53 UTC
But it is still old winsys.
Comment 9 Marian Mirilovic 2004-06-14 14:07:22 UTC
re-evaluate please ...
Comment 10 Milos Kleint 2004-06-29 13:28:08 UTC
makes no sense to have it open. is not an issue with 3.6 and promo-d
versions.
closing as wontfix.
Comment 11 Marian Mirilovic 2005-07-12 10:03:02 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo