Bug 33381 - com.sun.java.swing.plaf.gtk.GTKLookAndFeel crashes
com.sun.java.swing.plaf.gtk.GTKLookAndFeel crashes
Status: CLOSED DUPLICATE of bug 32637
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Linux
: P1 (vote)
: TBD
Assigned To: _ tboudreau
issues@platform
: L&F
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 17:04 UTC by _ hair
Modified: 2008-12-22 20:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ hair 2003-05-03 17:04:53 UTC
Product Version       = NetBeans IDE 3.5 RC1
(Build 200304292350)
  IDE Versioning        = IDE/1 spec=3.42.1
impl=200304292350
  Operating System      = Linux version
2.4.18-27.8.0 running on i386
  Java; VM; Vendor      = 1.4.2-beta; Java
HotSpot(TM) Client VM 1.4.2-beta-b19; Sun
Microsystems Inc.
  Java Home             = /usr/java/j2sdk1.4.2/jre
  System Locale; Encod. = en_AU; UTF-8
-----------------------------------------------------

When I try to add:
-ui com.sun.java.swing.plaf.gtk.GTKLookAndFeel
to the ide.cfg I get:


java.lang.NullPointerException
	at
javax.swing.JTable.setSelectionBackground(JTable.java:1638)
	at
javax.swing.plaf.basic.BasicTableUI.installDefaults(BasicTableUI.java:637)
	at
javax.swing.plaf.basic.BasicTableUI.installUI(BasicTableUI.java:618)
	at javax.swing.JComponent.setUI(JComponent.java:449)
	at javax.swing.JTable.setUI(JTable.java:2621)
	at
org.openide.explorer.view.TreeTable.updateUI(TreeTable.java:122)
	at javax.swing.JTable.<init>(JTable.java:371)
	at javax.swing.JTable.<init>(JTable.java:295)
	at
org.openide.explorer.view.TreeTable.<init>(TreeTable.java:61)
	at
org.openide.explorer.view.TreeTableView.initializeTreeTable(TreeTableView.java:245)
	at
org.openide.explorer.view.TreeTableView.<init>(TreeTableView.java:100)
	at
org.openide.explorer.view.TreeTableView.<init>(TreeTableView.java:91)
	at
org.netbeans.modules.tasklist.core.TaskListView$MyTreeTable.<init>(TaskListView.java:332)
	at
org.netbeans.modules.tasklist.core.TaskListView.componentOpened(TaskListView.java:205)
	at
org.netbeans.modules.tasklist.suggestions.SuggestionsView.componentOpened(SuggestionsView.java:245)
	at
org.openide.windows.WindowManager.componentOpenNotify(WindowManager.java:190)
	at
org.netbeans.core.windows.WindowManagerImpl.access$1701(WindowManagerImpl.java:77)
	at
org.netbeans.core.windows.WindowManagerImpl$TopComponentManager.doOpen(WindowManagerImpl.java:1635)
	at
org.netbeans.core.windows.WindowManagerImpl$TopComponentManager.open(WindowManagerImpl.java:1589)
	at
org.openide.windows.TopComponent.open(TopComponent.java:217)
	at
org.openide.explorer.ExplorerPanel.open(ExplorerPanel.java:124)
	at
org.netbeans.core.windows.layers.TCRefImpl.performCommand(TCRefImpl.java:157)
	at
org.netbeans.core.windows.DeferredPerformer.processCommand(DeferredPerformer.java:195)
	at
org.netbeans.core.windows.DeferredPerformer.putRequest(DeferredPerformer.java:89)
	at
org.netbeans.core.windows.layers.TCRefImpl.updateMode(TCRefImpl.java:209)
	at
org.netbeans.core.windows.layers.ModeData$CookiesImpl.addComponents(ModeData.java:830)
	at
org.netbeans.core.windows.layers.ModeData$CookiesImpl.updateComponents(ModeData.java:666)
	at
org.netbeans.core.windows.layers.ModeData$CookiesImpl.updateAll(ModeData.java:414)
	at
org.netbeans.core.windows.layers.ModeData$CookiesImpl.loadDataSection(ModeData.java:1260)
	at
org.netbeans.core.windows.ModeImpl.ensureSectionLoaded(ModeImpl.java:2402)
	at
org.netbeans.core.windows.ModeImpl.setVisible(ModeImpl.java:1318)
	at
org.netbeans.core.windows.WorkspaceVisibilityManager.setModesVisibility(WorkspaceVisibilityManager.java:544)
	at
org.netbeans.core.windows.WorkspaceVisibilityManager.processModes(WorkspaceVisibilityManager.java:381)
	at
org.netbeans.core.windows.WorkspaceVisibilityManager.doSetVisible(WorkspaceVisibilityManager.java:187)
	at
org.netbeans.core.windows.WorkspaceVisibilityManager.performCommand(WorkspaceVisibilityManager.java:110)
	at
org.netbeans.core.windows.DeferredPerformer.processCommand(DeferredPerformer.java:195)
	at
org.netbeans.core.windows.DeferredPerformer.stateChanged(DeferredPerformer.java:159)
	at
org.netbeans.core.windows.StateManager.fireStateChanged(StateManager.java:128)
	at
org.netbeans.core.windows.StateManager.setVisibilityState(StateManager.java:153)
	at
org.netbeans.core.windows.StateManager.propertyChange(StateManager.java:175)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:330)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:257)
	at
java.awt.Component.firePropertyChange(Component.java:6694)
	at
org.netbeans.core.windows.MainWindow.doShowWindow(MainWindow.java:190)
	at
org.netbeans.core.windows.MainWindow.access$100(MainWindow.java:51)
[catch] at
org.netbeans.core.windows.MainWindow$2.run(MainWindow.java:165)
	at
java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
	at
java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at
java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
-----------------------------------------------------

The om.sun.java.swing.plaf.gtk.GTKLookAndFeel
works fine for other Java apps on my machine.
Comment 1 Marian Mirilovic 2003-05-05 08:35:49 UTC

*** This issue has been marked as a duplicate of 32637 ***
Comment 2 Jan Chalupa 2003-05-05 08:43:33 UTC
Dupplicate of issue #32637. A known problem with JDK 1.4.2-beta. Will
be addressed in the final release of 1.4.2

For more info, see:
http://developer.java.sun.com/developer/bugParade/bugs/4844870.html
Comment 3 _ hair 2003-05-05 11:27:40 UTC
excellent. marking closed.
(sorry I searched for the duplicate before entering but obviously did
not find it).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo