Bug 33246 - I18N - Ensure all non-HTML components in the IDE correctly honor font size
I18N - Ensure all non-HTML components in the IDE correctly honor font size
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
All All
: P2 (vote)
: TBD
Assigned To: _ tboudreau
issues@platform
: I18N, UMBRELLA
: 33928 (view as bug list)
Depends on: 34379 33212 33247 33248 33249 33250 33546 33666 33667 33668 33672 33698 33699 33700 33701 33702 33703 33786 33790 33791 33796 33872 33873 33874 33875 33876 33877 33878 33881 33884 33948 33949 33950 33966 33988 34021 34030 34061 34063 34103 34104 34105 34157 34188 34189 34238 34434 34450 34490 34536 34714
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-25 09:16 UTC by _ tboudreau
Modified: 2008-12-22 19:57 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2003-04-25 09:16:39 UTC
For the case of Chinese localizations, and possibly others,
a larger font size is needed - 12 or better 14.

A number of components do not honor font size 
appropriately.  An initial survey indicates the following
items, which I will file individual issues on:
 - Tree table view - row height should be calculated from
   the font before the first paint
 - Internal frame title bars - ignore the font settings
 - Setup wizard - some lines overwritten by others

It may be necessary to eliminate the hard coded font
sizes specified during startup in org.netbeans.core.Main.
Comment 1 Jesse Glick 2003-04-25 16:05:31 UTC
- I am in favor of getting rid of the hardcoded font size spec since
it is the L&F's job to decide what the base font should be.

- Marking I18N since this has an impact on some localizations, e.g.
Chinese.

- Re. HTML display, actually this should set basefont according to the
L&F's base text font. I have filed #4599503 which relates to this, but
I am not sure if that captures the actual problem (does this still
exist in 1.4?) that UIManager should control the basefont for HTML
rendering.
Comment 2 Ken Frank 2003-04-25 22:15:59 UTC
We (i18n testing) has been in touch with Tim on this and
will expand our testing to use larger font to trigger
more of these issues if they exist. We've been testing all along
with pseudo localized messages that expand each label/message
by some amount, but it looks like using bigger fonts with this
will help catch more of these issues; since in case of hard coding
I think that one would need to have a given message exceed that 
hardcoded limit, theres not one optimal length/font size combo
to work for all; but we've already seen some other issues than
Tim mentions below that we'll be filing also.
Comment 3 David Simonek 2003-05-28 14:57:10 UTC
*** Issue 33928 has been marked as a duplicate of this issue. ***
Comment 4 David Simonek 2003-05-29 17:31:30 UTC
I'm working on this issue...
Comment 5 _ rkubacki 2004-08-23 15:28:44 UTC
This is an umbrella task for NB3.5. Shouldn't we close it now? Is
there actual one for NB4.0?
Comment 6 _ tboudreau 2004-08-23 17:10:01 UTC
I'd say so.  

Note that -fontsize is completely non-supportable on GTK L&F, also.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo