Bug 33129 - TopComponent.getSystemActions() provides CloneViewAction even if TopComponent.Cloneable is not implemented
TopComponent.getSystemActions() provides CloneViewAction even if TopComponent...
Status: CLOSED DUPLICATE of bug 33557
Product: platform
Classification: Unclassified
Component: Window System
3.x
All All
: P4 (vote)
: 3.x
Assigned To: mslama
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-22 15:49 UTC by _ tboudreau
Modified: 2008-12-22 18:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2003-04-22 15:49:45 UTC
See issue 33117, CCE on clone action in output window.
The core problem is that OutputTabTerm does not
implement
TopComponent.Cloneable, but CloneViewAction is
supplied
anyway.
Comment 1 Jesse Glick 2003-04-22 17:53:28 UTC
Agreed that it is a poor default, but does not seem critical - any
component has the opportunity to override the list with a better set
of actions. Thus only really affects module developers, assuming all
kinds of TC's used in NetBeans have been checked for a sane action list.
Comment 2 mslama 2003-05-14 12:33:08 UTC
Fixed as part of issue #33557.
Comment 3 mslama 2003-05-14 12:33:29 UTC

*** This issue has been marked as a duplicate of 33557 ***
Comment 4 Marian Mirilovic 2003-07-23 15:52:17 UTC
verified, closed - it's duplicate.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo