Bug 33110 - Clone View throws java.lang.ClassCastException
Clone View throws java.lang.ClassCastException
Status: CLOSED INVALID
Product: platform
Classification: Unclassified
Component: Window System
3.x
Sun Solaris
: P2 (vote)
: TBD
Assigned To: mslama
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-22 08:44 UTC by Keiichi Oono
Modified: 2008-12-23 10:42 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
ide.log file when an Exception was thrown (12.07 KB, text/plain)
2003-04-22 08:46 UTC, Keiichi Oono
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keiichi Oono 2003-04-22 08:44:58 UTC
Sun ONE Studio 5 (Build 030416)
JDK 1.4.1_01

To reproduce:
- right-click output window tab and select Clone
View
- right-click project tab in explorer window and
select Clone View

ClassCastException is thrown.
I attache ide.log in this report.
Comment 1 Keiichi Oono 2003-04-22 08:46:33 UTC
Created attachment 10057 [details]
ide.log file when an Exception was thrown
Comment 2 mslama 2003-04-22 10:23:21 UTC
The problem is that given TopComponents provide CloneViewAction but
they do not implement it. So they should either provide and implement
it or not provide it. (In addition action could be also
enabled/disabled but when TopComponent does not want to be clonable it
should not provide CloneViewAction.)
Comment 3 mslama 2003-04-22 10:36:30 UTC
I filed 2 separate issues #33116 for ProjectsTab and #33117 for
OutputTabTerm.
Comment 4 mslama 2003-04-22 12:27:04 UTC
As I filed another issues instead of this issue I will close this issue.
Comment 5 Marian Mirilovic 2003-04-23 10:51:48 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo