Bug 33097 - AU(Crimson) cannot parse Unicode entity includes
AU(Crimson) cannot parse Unicode entity includes
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Autoupdate
3.x
PC Linux
: P4 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
: I18N
: 7946 (view as bug list)
Depends on:
Blocks: 22948 33098
  Show dependency treegraph
 
Reported: 2003-04-21 16:20 UTC by Jesse Glick
Modified: 2006-10-23 16:39 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace (2.22 KB, text/plain)
2003-04-21 16:20 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-04-21 16:20:08 UTC
Create a new update center with URL

http://www.netbeans.org/updates/alpha/dev_alpha_daily.xml

(Workaround for issue #32774.)

Try to connect to it. You can't; the parsing fails
for no reason:

Annotation: URL:
http://www.netbeans.org/updates/alpha/dev_alpha_daily.xml
Annotation: Parse error in file
http://www.netbeans.org/updates/alpha/dev_alpha_daily.ent
line 2,512 column -1 (PUBLIC null)
org.xml.sax.SAXParseException: Character
conversion error: "Illegal ASCII character, 0xe3"
(line number may be too low).
	at
org.apache.crimson.parser.InputEntity.fatal(InputEntity.java:1100)

Actually in dev_alpha_daily.ent, the character in
question is further down, in the Japanese
localization of the Ant module.

Note that dev_alpha_daily.ent is included from
dev_alpha_daily.xml as an entity include, and
correctly includes the declaration

<?xml version="1.0" encoding="UTF-8"?>

at the top. Nonetheless, Crimson seems to be too
stupid to understand this and is apparently
attempting to parse it as ASCII.

If you connect to e.g.:

file:/space/src/nb_all/www/www/updates/alpha/dev_alpha_daily.xml

i.e. the same URL on local disk, then it is OK.
(Except for issue #33095, but that is not fatal -
other modules are still displayed.) It is only the
http: version of the file that is unparsable, for
whatever reason.

This seems to be a Crimson bug. (I am using JDK
1.4.2 b19 on Linux.) Xerces seems to work
correctly, so the workaround is to add this to
your $nbhome/bin/ide.cfg:

-J-Djavax.xml.parsers.DocumentBuilderFactory=org.apache.xerces.jaxp.DocumentBuilderFactoryImpl

Another workaround be to inline the entity
includes on the website, I suppose - I have not
tried it.
Comment 1 Jesse Glick 2003-04-21 16:20:41 UTC
Created attachment 10051 [details]
Stack trace
Comment 2 Petr Hrebejk 2003-04-22 14:22:08 UTC
Yes it looks like a bug in Crimson. Seems like the only difference
between file:// and http:// connection is that the first one retuns
contentType unknown the second one returns text/xml. Making the server
to return proper encoding could help but is probably impossible to 
achieve on NetBeans server. 
I've tested Jesses second proposal for not using !ENTITY in the
XML file and it works. I'll try to organize this for the NetBeans
server. I don't put some hacks into the Au client to obtain xerces
instead of crimson.
Comment 3 Petr Hrebejk 2003-04-22 15:08:14 UTC
Adding Robert Novak on CC. The NetBeans AU center should avoid using
XML entities. This will workaround the bug in the Crimson parser.

However the issue with crimson should be solved somehow. Not sure how.
Comment 4 Jesse Glick 2003-04-22 18:02:41 UTC
I think Ruda actually handles the daily alpha build.

Funny about the Content-Type - text/xml is the *correct* type for the
*.ent file. Hmm. Maybe if the Crimson problem can be reproduced in a
standalone app, file a bug on xml.apache.org.
Comment 5 _ mihmax 2003-04-27 08:40:47 UTC
*** Issue 33264 has been marked as a duplicate of this issue. ***
Comment 6 _ mihmax 2003-04-27 08:44:10 UTC
I suggest this issue be P2, bacause it blocks me connecting to
NetBeans Alpha AU server
Comment 7 Jesse Glick 2003-04-27 17:22:18 UTC
Need not be P2. This bug has already been worked around, as Petr
mentioned, and is lower priority. Issue #33264 is unrelated.
Comment 8 _ mihmax 2003-05-04 20:15:55 UTC
What's the issue # of a workaround?
Comment 9 rbalada 2003-05-05 10:34:55 UTC
Maxym,

I guess, that the workaround is to not use reference to external
!ENTITY within the .xml file.
Comment 10 Petr Hrebejk 2003-11-06 14:33:04 UTC
*** Issue 7946 has been marked as a duplicate of this issue. ***
Comment 11 Marian Mirilovic 2003-12-01 10:48:39 UTC
reassigne to Jirka - new owner of autoupdate
Comment 12 Jiri Rechtacek 2004-03-17 09:34:20 UTC
Seems as WONTFIX. Crimson is not used in AU anymore. Reopen if I'm wrong.
Comment 13 Jiri Rechtacek 2004-03-17 15:30:24 UTC
Oops, I'm wrong, openide.xml/XMLUtil.parse() returns crimson still. I
reopen it. It's this bug still anywhere visible?
Comment 14 Jesse Glick 2004-03-18 10:30:50 UTC
It is presumably still visible if you have an UC XML file using entity
includes. Currently netbeans.org does not but someone else may well
try it.
Comment 15 Jesse Glick 2004-08-17 04:04:30 UTC
Probably not high priority.
Comment 16 Marian Mirilovic 2004-12-21 09:28:58 UTC
I guess this won't be fixed for NB4.0 , please evaluate again.
Comment 17 Jiri Rechtacek 2006-08-10 14:28:40 UTC
I feel it's problem won't be tracked no longer. No other bugs don't depend on
this. Closed as WONTFIX.
Comment 18 Jiri Rechtacek 2006-08-10 14:29:30 UTC
x
Comment 19 Jiri Rechtacek 2006-08-10 14:30:26 UTC
I feel it's problem won't be tracked no longer. No other bugs don't depend on
this. Closed as WONTFIX.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo