Bug 32938 - XML Schema validation fails for XML Schema instance
XML Schema validation fails for XML Schema instance
Status: VERIFIED WONTFIX
Product: xml
Classification: Unclassified
Component: Schema
3.x
PC Windows ME/2000
: P4 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@xml
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-16 10:16 UTC by vtec
Modified: 2009-11-07 11:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Failing XML schema (4.90 KB, text/xml)
2003-04-16 10:18 UTC, vtec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vtec 2003-04-16 10:16:58 UTC
When invoking "Validate XML" command from the
context menu during XML schema development it
fails with this text:

Checking file:/C:/Documents and
Settings/cvachoucek/projects/Unimarc/data/Catalog_1.xsd...
cvc-datatype-valid.1.2.1: 'file:/C:/Documents and
Settings/cvachoucek/projects/Unimarc/data/Catalog_1.xsd'
is not a valid 'anyURI' value. [1] 
XML validation finished.

In the IDE log there is this stack trace:

Annotation: SAXEntityParser: filtering out:
Annotation: Parse error in file file:/C:/Documents
and
Settings/cvachoucek/projects/Unimarc/data/Catalog_1.xsd
line 1 column 182 (PUBLIC -//NetBeans//Fake Public
ID 1050484040358//EN)
org.xml.sax.SAXParseException: cvc-elt.1: Cannot
find the declaration of element 'schemaWrapper'

If the Catalog.xsd file is moved into directory
like "C:\temp" then the validation succeeds, so I
consider the empty spaces in 'Documents and
Settings' to suspected.

The failing XML Schema is attached. This problem
did not appear with Netbeans 3.4.1.
Comment 1 vtec 2003-04-16 10:18:34 UTC
Created attachment 9968 [details]
Failing XML schema
Comment 2 _ pkuzel 2003-04-16 13:27:07 UTC
It's related to the space in path. Once placed into spaceless named directory all works 
for me. I guess it could be duplicate of issue 32594. 
 
The exception in log appears only in development version. It's harmless. 
Comment 3 _ pkuzel 2003-04-16 14:47:01 UTC
Duplicating with more generic higher priority issue. 

*** This issue has been marked as a duplicate of 32594 ***
Comment 4 Milan Kuchtiak 2004-02-05 15:27:02 UTC
I am reopening the issue, because issue 32594 was originaly reported
for DTD files. The problem with DTD files has already been fixed but
this issue remains.
Comment 5 Milan Kuchtiak 2004-02-05 15:52:29 UTC
It's a Xerces bug.
See : <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18803>
Comment 6 Mikhail Matveev 2007-09-20 14:46:44 UTC
Verified - fixed long time ago
Comment 7 Quality Engineering 2009-11-02 11:15:56 UTC
NetBeans.org Migration: changing resolution from LATER to WONTFIX


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo