Bug 32909 - Hitting ESC in Explorer pop-up search field behaves poorly
Hitting ESC in Explorer pop-up search field behaves poorly
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
: FOCUS, REGRESSION, UI
: 33993 (view as bug list)
Depends on: 30160
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-15 15:15 UTC by Jesse Glick
Modified: 2008-12-22 18:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-04-15 15:15:31 UTC
r35 & dev both.

Open NB e.g. on a fresh user dir. With sampledir
selected in the Explorer (w/ focus), type 'c' to
start to select 'colorpicker'. Now change your
mind and press Escape to cancel.

1. The selection is left on colorpicker. It should
have been set back to sampledir where you started,
just like in any search that you cancel.
Similarly, if you press Backspace to delete the
'c', the search should back up to where it started.

2. The focus is no longer on the Explorer tree! It
is on the scroll bar. You have to press Shift-TAB
(or Ctrl-2) to get focus back on the tree. This is
annoying.
Comment 1 Jiri Rechtacek 2003-04-15 16:11:24 UTC
add.2: really bug; it's a unwanted regression of Tim's fix of 30160,
it is fixed in maintrunk now.
add.1: I'm not sure what behavior could be correct. I'm used to select
some folder by navigator, press Esc and continue with work. If Ecs
restored previous selection then it could be confused why a selected
nodes was changed. Can be fix of 2nd enough? Or should it tracked as
UI defect?
Comment 2 Jiri Rechtacek 2003-04-15 16:13:01 UTC
Jesse, if you are think 1st part should be solved too, reopen it. Thanks
Comment 3 Jesse Glick 2003-04-15 16:33:28 UTC
Your explanation of the behavior of ESC does make sense; it should
leave selection on the last selected item.

However Backspace does not work correctly. I will open that separately.
Comment 4 Jesse Glick 2003-04-15 16:39:44 UTC
Opened 2nd half of #1 as issue #32915 for separate tracking.
Comment 5 Jiri Rechtacek 2003-05-29 11:48:48 UTC
*** Issue 33993 has been marked as a duplicate of this issue. ***
Comment 6 Lukas Hasik 2003-06-11 15:13:21 UTC
x
verified
please, fix part #2, too.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo