Bug 32880 - Open files from Search Results & close SR -> focus but not selection on editor
Open files from Search Results & close SR -> focus but not selection on editor
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: Peter Zavadsky
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-14 20:22 UTC by Jesse Glick
Modified: 2008-12-23 09:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot (63.23 KB, image/png)
2003-04-14 20:23 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-04-14 20:22:23 UTC
[r35, or dev apr 09] Start NB with fresh user dir.
Click on 'examples' in Explorer. Ctrl-F. Type
"colorprev" in search field, hit Enter. Select
ColorPreview and ColorPreviewBeanInfo in search
results list. Press Sh-F10 -> Open to open these
files in the editor, then Alt-C to close search
results window. Now try to use Alt-Left or
Alt-Right to switch tabs - does not work, just
beeps. Property sheet is empty, all node actions
off, etc. Yet the cursor is blinking in the editor
window. It seems that the editor window correctly
has KB focus - and there is a blue bar around it -
yet there was no notification to other components
that the editor window is now the selected TC or
mode or whatever.

See screenshot. I have just selected a block of
text with shift + arrow keys, and pressed Alt-W.
Note that the Window menu does not have "Source
Editor" selected, nor is Next View/Prev View
enabled, nor various node actions in the toolbar.

Note that if in my Linux window manager (Sawfish,
sloppy focus) you press Alt-TAB twice to focus
some other app and back, then NetBeans realizes
that the editor is focused and everything begins
working again. Or if you press Ctrl-2 Ctrl-3, or
click on another part of the NetBeans MDI window
and back to the editor, etc., the situation is
corrected.

I have observed a similar bug in the Explorer,
where e.g. the Filesystems tab appears to have
focus yet Alt-Left and Alt-Right are not working.
However I do not know how to reproduce that.

User impact: temporary confusion that keyboard
shortcuts are not apparently working, actions are
disabled, etc.
Comment 1 Jesse Glick 2003-04-14 20:23:24 UTC
Created attachment 9936 [details]
Screenshot
Comment 2 mslama 2003-04-15 10:05:43 UTC
It is strange because winsys performs TopComponent activation when it
receives FOCUS_GAINED event for given TopComponent (or any of its
subcomponent) and when focus is in editor TopComponent should be
activated too. Need to investigate.
Comment 3 Marian Mirilovic 2003-11-26 12:58:39 UTC
Because Window System v1 will not be supported from now by our team, all old
winsys issues (now "core/window system v1" issues) are going to be closed as
WONTFIX. 

Changes in API which emerged both from UI spec 
and problems with adjusting to the older API are described in the document
http://core.netbeans.org/windowsystem/changes.html.
 It shows also recommends how the client code should be adjusted to the new
window system.

If you think this issue apply also to the new winsys then change the
subcomponent (to "core/window system") and REOPEN it.
Comment 4 Marian Mirilovic 2004-02-27 14:13:02 UTC
issue doesn't apply to new window system - verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo