Bug 32871 - I18N - Chinese multibyte not appear correctly in all panels
I18N - Chinese multibyte not appear correctly in all panels
Status: RESOLVED INVALID
Product: installer
Classification: Unclassified
Component: Code
3.x
Sun Solaris
: P2 (vote)
: TBD
Assigned To: Richard Gregor
issues@installer
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-14 17:25 UTC by Ken Frank
Modified: 2006-01-04 15:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Chinese test messages (3.26 KB, image/gif)
2003-04-14 17:36 UTC, Ken Frank
Details
chinese messages (3.65 KB, image/gif)
2003-04-14 17:41 UTC, Ken Frank
Details
chinese test messages (3.21 KB, image/gif)
2003-04-14 17:43 UTC, Ken Frank
Details
chinese test message (4.71 KB, image/gif)
2003-04-14 17:43 UTC, Ken Frank
Details
chinese test message (3.35 KB, image/gif)
2003-04-14 17:44 UTC, Ken Frank
Details
chinese test message (3.40 KB, image/gif)
2003-04-14 17:45 UTC, Ken Frank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2003-04-14 17:25:26 UTC
Using test    installers with Chinese messages,
and running in     Chinesee locales on solaris,
not all the multibyte on panels looks correct,
but it seems that overall the fonts are set
correctly to view it, since some multibyte
on a given panell does look ok - see attachments.
Comment 1 Ken Frank 2003-04-14 17:36:38 UTC
Created attachment 9926 [details]
Chinese test messages
Comment 2 Ken Frank 2003-04-14 17:41:04 UTC
Created attachment 9927 [details]
chinese messages
Comment 3 Ken Frank 2003-04-14 17:43:00 UTC
Created attachment 9928 [details]
chinese test messages
Comment 4 Ken Frank 2003-04-14 17:43:41 UTC
Created attachment 9929 [details]
chinese test message
Comment 5 Ken Frank 2003-04-14 17:44:36 UTC
Created attachment 9930 [details]
chinese test message
Comment 6 Ken Frank 2003-04-14 17:45:23 UTC
Created attachment 9931 [details]
chinese test message
Comment 7 Richard Gregor 2003-04-15 07:48:40 UTC
Please, did you use Solaris add-on for Simplified Chinese? It should
be available on http:www./Java/VMs/18030-Simp. Chinese . 

There are known issues related to installshield and this language
support - I sent html page from doc to you. As I see there is problem
with text on standard buttons - it is done in installshield's code.
Font for panels is set to Dialog 12pt. 
Comment 8 Ken Frank 2003-04-21 21:24:33 UTC
Running test installer in simplified chinese windows 2000,
all the multibyte displays correctly.

This seems then to be unix or solaris issue.
Comment 9 Ken Frank 2003-04-24 23:23:01 UTC
I am closing this now; I asked others at l10n center and on my
team to try it and it worked on their S9U2. As it works for me
on S8, I will have to assume its some heretofore unseen 
font pkg issue.

ken.frank@sun.com
04-24-2003


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo