Bug 32608 - Installer throws ZipException and tar.gz has bad Zipfile
Installer throws ZipException and tar.gz has bad Zipfile
Status: RESOLVED INVALID
Product: installer
Classification: Unclassified
Component: Code
3.x
PC Linux
: P1 (vote)
: TBD
Assigned To: issues@installer
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-03 17:06 UTC by dingodave
Modified: 2003-04-08 08:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dingodave 2003-04-03 17:06:33 UTC
Downloaded
NetBeansIDE-release35-200304012350-linux.bin
chmod u+x NetBeansIDE-release35-200304012350-linux.bin
run NetBeansIDE-release35-200304012350-linux.bin
Input install path as /usr/local/share/netbeans
(exists and is writable for ug)
Ran the installer as root also, same exact results:

got "Error occurred during the installation" in
the install window with 
"One or more errors occurred during the
replacement of files
(bean10) with files (bean10). Refer to the
uninstall log for additional information."

as the explanation.

From log file:

(Apr 3, 2003 9:45:51 AM), Setup.product.install,
com.installshield.product.service.product.PureJavaProductServiceImpl$DiskSpaceCheck,
wrn, Checking required disk space requires file
service native support.
(Apr 3, 2003 9:45:52 AM), Setup.product.install,
com.installshield.product.actions.Files, wrn,
Cannot set file attributes: operation is not
supported by the current file service implementation.
(Apr 3, 2003 9:46:01 AM), Setup.product.install,
com.installshield.product.actions.Files, wrn,
Cannot set file times: operation is not supported
by the current file service implementation.
(Apr 3, 2003 9:46:03 AM), Setup.product.install,
com.installshield.product.actions.Files, err,
java.util.zip.ZipException: incorrect data check
STACK_TRACE: 16
java.util.zip.ZipException: incorrect data check
        at
com.installshield.archive.index.ISInflaterInputStream.read(CompressedURLConnection.java:147)
        at
java.io.FilterInputStream.read(FilterInputStream.java:90)
        at
com.installshield.product.actions.Files.copy(Files.java:700)
        at
com.installshield.product.actions.Files.copyFileWithFileService(Files.java:737)
        at
com.installshield.product.actions.Files.install(Files.java:378)
        at
com.installshield.product.service.product.PureJavaProductServiceImpl.installProductAction(PureJavaProductServiceImpl.java:1868)
        at
com.installshield.product.service.product.PureJavaProductServiceImpl$InstallProduct.getResultForProductAction(PureJavaProductServiceImpl.java:4649)
        at
com.installshield.product.service.product.InstallableObjectVisitor.visitComponent(InstallableObjectVisitor.java:365)
        at
com.installshield.product.service.product.InstallableObjectVisitor.visitInstallableComponents(InstallableObjectVisitor.java:325)
        at
com.installshield.product.service.product.InstallableObjectVisitor.visitProductBeans(InstallableObjectVisitor.java:135)
        at
com.installshield.product.service.product.PureJavaProductServiceImpl$InstallProduct.install(PureJavaProductServiceImpl.java:4276)
        at
com.installshield.product.service.product.PureJavaProductServiceImpl$Installer.execute(PureJavaProductServiceImpl.java:3652)
        at
com.installshield.wizard.service.AsynchronousOperation.run(AsynchronousOperation.java:40)
        at java.lang.Thread.run(Thread.java:536)
Comment 1 Richard Gregor 2003-04-08 08:45:01 UTC
I can't reproduce this so signig as invalid.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo