Bug 32594 - Space in name bug (no protocol from validation)
Space in name bug (no protocol from validation)
Status: CLOSED FIXED
Product: xml
Classification: Unclassified
Component: Code
3.x
PC Linux
: P2 (vote)
: 3.x
Assigned To: Milan Kuchtiak
issues@xml
3.5_CANDIDATE
: RELNOTE, SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-03 11:50 UTC by Martin Schovanek
Modified: 2007-09-25 01:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2003-04-03 11:50:03 UTC
[Nb Build 200304012350, jdk1.4.1_02]

Validate XML and Code  Completion fail in case the
XML document name includes space.

Steps to reproduce:
===================
1) create XML and DTD document like:

=== 'do c.xml':
<!DOCTYPE root SYSTEM "dtd.dtd">
<root/>

=== 'dtd.dtd':
<!ELEMENT root EMPTY>

2) validate the 'do c.xml' document.

Warning appears in output window:

Checking file:/space/.../do c.xml
Warning: Cannot resolve "<missing public ID>" to
URL, using "dtd.dtd"...
no protocol: dtd.dtd [1] 
XML validation finished.
Comment 1 Patrick Keegan 2003-04-04 14:26:11 UTC
Proposed release note:

"If the name of an XML document contains a space, code completion and the Validate XML command do not 
work."

Anything else I should mention?
Comment 2 Martin Schovanek 2003-04-07 14:46:28 UTC
The proposed text is sufficient, I agree with it.
Comment 3 _ pkuzel 2003-04-08 10:06:47 UTC
It's a bug <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18803>
in underlaying Xerces parser.
Comment 4 _ pkuzel 2003-04-16 14:45:33 UTC
The problem also appears if path to document grammar (either DTD or XSD) contains  
space. See issue 32938. 
Comment 5 _ pkuzel 2003-04-16 14:46:59 UTC
*** Issue 32938 has been marked as a duplicate of this issue. ***
Comment 6 Patrick Keegan 2003-04-16 14:53:17 UTC
updated release note
Comment 7 _ pkuzel 2003-04-17 14:43:03 UTC
It comes from XMLEntityManager which fails to properly expand system
ID that contains spaces.

I checked recent Xerces 2.4.0 and found that the bug was eliminated
for DTD constrained documents. For XMLSchema constrained ones it
reports Invalid URI <theURI> at [1]. So it looks that the fix cannot
be easily backported.
Comment 8 _ pkuzel 2003-04-17 15:58:38 UTC
So with Xerces 2.4.0 there's an extra error message appended to
checker output if it checks XML schema based documents. Any user
errors are properly reported.

The extra message is confusing for valid user documents.
Comment 9 _ pkuzel 2003-04-17 16:27:52 UTC
URI vs. URL handling discrepances are tracked in java bugparade under
4850066.
Comment 10 _ pkuzel 2003-07-30 14:41:40 UTC
Xerces 2.4.0 in now available under libs/xerces project.
Comment 11 _ pkuzel 2003-11-04 10:15:30 UTC
See also issue 36998, the same problem exists for transformations too.
Comment 12 _ pkuzel 2003-11-04 10:17:04 UTC
*** Issue 36998 has been marked as a duplicate of this issue. ***
Comment 13 _ pkuzel 2003-11-04 10:18:46 UTC
It's in relnotes there is FAQ but it needs to be fixed too.
Comment 14 Petr Jiricka 2004-02-04 13:45:58 UTC
Milane, can you please take care of this bug? Either fix it, or waive
it. Thanks.
Comment 15 Milan Kuchtiak 2004-02-05 13:57:25 UTC
On windows-2000 validation and code-completion works normally.
Comment 16 Milan Kuchtiak 2004-02-05 15:34:54 UTC
Fixed by another fix :
See : <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18803>

I reopened the issue 32938 and issue 36998.
Those issues are related more to XML schema.
Comment 17 Martin Schovanek 2004-03-02 10:17:52 UTC
v
Comment 18 Patrick Keegan 2004-03-03 22:49:32 UTC
Is there any reason to keep the RELNOTE keyword here? Might people be
using a bad version of Xerces?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo