Bug 32437 - I18N - Localized NBMs do not include distribution attr
I18N - Localized NBMs do not include distribution attr
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Builds & Repositories
3.x
All All
: P2 (vote)
: 3.x
Assigned To: nbbuild-issues@ide
nbbuild-issues@ide
: I18N
Depends on:
Blocks: 33098 34028
  Show dependency treegraph
 
Reported: 2003-03-27 20:04 UTC by Jesse Glick
Modified: 2005-02-07 15:12 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Suggested patch (2.13 KB, patch)
2003-03-27 20:05 UTC, Jesse Glick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-03-27 20:04:49 UTC
Thus it is impossible to include them in an update
description file - they could not be downloaded.
And the validation of the update desc XML file
fails too, as it should.

<locmakenbm> needs to include this attr.

Including suggested technique, but it could be
refined as desired.
Comment 1 Jesse Glick 2003-03-27 20:05:14 UTC
Created attachment 9579 [details]
Suggested patch
Comment 2 _ mihmax 2003-03-27 20:13:13 UTC
Well, this bug shold have arised sooner or later.
Actually, when we discussed the new-l10n-way, the only thing we missed
was the distribution parameter.

Please also remove the comment "Decide how to..."

Thanks for help, Jesse,
I'm real 0 (= dude) in NB AU quirks
Comment 3 rbalada 2003-03-28 11:28:56 UTC
Jesse,
the suggested patch is in conflict with other modules NBM build.
All the build scripts keep property dist.base defined w/o protocol and
the "http://" protocol string is hardcoded in each <makenbm> task.
I know, that hardocoded assumption of "http://" protocol is not good
idea, but applying your patch would require to patch build
infrastructure and build scripts of all modules on release35 branch.

I would suggest to apply your patch only for LocMakeNBM with the
change to hardcode the "http://" string just before dist.base
property. After Tegal is in Final, the "http://" hardcoded string can
be removed from trunk. The current build infrastructure (same for dev
and 3.5) is not much flexible to allow different construction of
dist.base property value for 3.5 and dev builds. New build
infrastructure (not yet done) is separated by "codeline" so it's easy
to have different build logic.
Comment 4 Jesse Glick 2003-03-28 15:40:27 UTC
1. I have no idea what you mean by this conflicting with other
modules. Only <locmakenbm> is patched. It is used only by
translatedfiles AFAIK.

And re. use of the (evil) automatic "http://" prefix, I am not sure
what the problem is here. The patch does not do anything about this
prefix. It just looks for ${dist.base} and if present, calls
MakeNBM.setDistribution, which already applies the prefix when it is
needed.

The patch to LocMakeNBM.java is similar to just adding an attr:

<locmakenbm distribution="${dist.base}/foo.nbm" .../>

which is like how normal modules do <makenbm>. The only reason I did
not do that directly is because <locmakenbm> generates several NBMs
and the suffix (here "/foo.nbm") is going to be different for each one
(e.g. "/foo_ru.nbm" vs. "/foo_ja.nbm"), so you cannot just set it to
one value. It needs to be computed somehow (this is a little clumsy
but should work until something better is available).
Comment 5 Ken Frank 2003-03-31 21:06:23 UTC
added i18n to synopsis to aid for netbeans_ro tracking.
Comment 6 rbalada 2003-04-09 18:34:37 UTC
Jesse,

normal modules do 

<makenbm distribution="http://${dist.base}/foo.nbm" />

what is in conflict with the patch which turns that to
say
<makenbm distribution="${dist.base}/foo.nbm" />

For build of "daily-alpha-nbms" moduleconfig, the property dist.base
is set on command line, because the nbm will not reside on default
dist.base.
Comment 7 Jesse Glick 2003-04-09 18:50:41 UTC
Fine, so just ignore the part of the patch affecting
translatedfiles/build.xml (until prefix usage for dist.base is removed
everywhere - in the trunk I suppose). It doesn't matter; <locmakenbm>
with the patch should work with or without an explicit http:// prefix.
Either way, MakeNBM.setDistribution is called, which adds the prefix
as needed.
Comment 8 rbalada 2003-06-02 18:17:59 UTC
 nbcvs ci -m "Issue 32437. I18N - Localized NBMs do not include
distribution attr. Fixed by join of value in property dist.base and
localized filename." nbbuild/antsrc/org/netbeans/nbbuild/LocMakeNBM.java
Checking in nbbuild/antsrc/org/netbeans/nbbuild/LocMakeNBM.java;
/cvs/nbbuild/antsrc/org/netbeans/nbbuild/LocMakeNBM.java,v  <-- 
LocMakeNBM.java
new revision: 1.3.22.6; previous revision: 1.3.22.5
done
Processing log script arguments...
Mailing the commit message to cvs@nbbuild.netbeans.org (from
rbalada@netbeans.org)
Comment 9 Jesse Glick 2003-06-02 18:29:07 UTC
Cool. Fixed in the trunk too?
Comment 10 rbalada 2003-06-03 15:01:22 UTC
Reopening for trunk.
Comment 11 rbalada 2003-10-09 15:43:58 UTC
nbbuild/antsrc/org/netbeans/nbbuild/LocMakeNBM.java revision 1.7 for
sure contains these changes.
Comment 12 Jesse Glick 2003-10-09 18:53:38 UTC
Reopening for two violations I spotted in
www/www/updates/alpha/dev_1.6_.xml:

<module codenamebase="org.netbeans.modules.apisupport.lite"
        license="japanese_l10n-nbm-license.txt"
        downloadsize="9118"
>
  <l10n 
        langcode="ja"
        module_major_version="1"
        module_spec_version="0.6"
OpenIDE-Module-Name="&#26032;&#35215;&#12514;&#12472;&#12517;&#12540;&#12523;&#12454;&#12451;&#12470;&#12540;&#12489;"
OpenIDE-Module-Long-Description="Open API &#12434;&#20351;&#29992;&#12377;&#12427;&#21021;&#32026;&#12518;&#12540;&#12470;&#12540;&#12364;IDE
&#12363;&#12425; IDE &#12408;&#12398;&#31777;&#21336;&#12394;&#12514;&#12472;&#12517;&#12540;&#12523;&#25313;&#24373;&#12434;&#38283;&#30330;&#12391;&#12365;&#12427;&#12424;&#12358;&#12395;&#12377;&#12427;&#21336;&#19968;&#12398;&#12454;&#12451;&#12470;&#12540;
&#12489;&#12290;&#31777;&#21336;&#12395;&#12377;&#12427;&#12383;&#12417;&#12289;&#26368;&#12418;&#19968;&#33324;&#30340;&#12395;&#20351;&#29992;&#12373;&#12428;&#12427;&#12514;&#12472;&#12517;&#12540;&#12523;&#27231;&#33021;&#12384;&#12369;&#12364;&#30452;&#25509;&#25552;&#20379;
&#12373;&#12428;&#12414;&#12377;&#12290;Open API &#12434;&#30495;&#21091;&#12395;&#20351;&#29992;&#12375;&#12383;&#12356;&#12392;&#32771;&#12360;&#12427;&#38283;&#30330;&#32773;&#12399;&#12289;&#12371;&#12398;&#12514;&#12472;&#12517;&#12540;&#12523;
&#12395;&#12394;&#12356;&#12354;&#12425;&#12422;&#12427;&#25313;&#24373;&#27231;&#33021;&#12434;&#20633;&#12360;&#12289;&#12377;&#12409;&#12390;&#12398; API &#12489;&#12461;&#12517;&#12513;&#12531;&#12488;&#12418;&#21547;&#12435;&#12391;&#12356;&#12427;&#12289;
&#23436;&#20840;&#12394; API &#12469;&#12509;&#12540;&#12488;&#12514;&#12472;&#12517;&#12540;&#12523;&#12418;&#20837;&#25163;&#12377;&#12427;&#24517;&#35201;&#12364;&#12354;&#12426;&#12414;&#12377;&#12290;"
  />
</module>

and

<module codenamebase="org.netbeans.modules.apisupport.lite"
        license="russian_l10n-nbm-license.txt"
        downloadsize="8032"
>
  <l10n 
        langcode="ru"
        module_major_version="1"
        module_spec_version="0.6"
OpenIDE-Module-Name="&#1052;&#1072;&#1089;&#1090;&#1077;&#1088; &#1089;&#1086;&#1079;&#1076;&#1072;&#1085;&#1080;&#1103; &#1084;&#1086;&#1076;&#1091;&#1083;&#1103;"
OpenIDE-Module-Long-Description="&#1052;&#1072;&#1089;&#1090;&#1077;&#1088;, &#1087;&#1086;&#1079;&#1074;&#1086;&#1083;&#1103;&#1102;&#1097;&#1080;&#1081; &#1085;&#1086;&#1074;&#1080;&#1095;&#1082;&#1072;&#1084; &#1086;&#1089;&#1074;&#1086;&#1080;&#1090;&#1100;
Open API &#1076;&#1083;&#1103; &#1088;&#1072;&#1079;&#1088;&#1072;&#1073;&#1086;&#1090;&#1082;&#1080; &#1087;&#1088;&#1086;&#1089;&#1090;&#1099;&#1093; &#1084;&#1086;&#1076;&#1091;&#1083;&#1077;&#1081; &#1057;&#1088;&#1077;&#1076;&#1099; &#1074; &#1089;&#1072;&#1084;&#1086;&#1081; &#1089;&#1088;&#1077;&#1076;&#1077;. &#1044;&#1083;&#1103;
&#1087;&#1088;&#1086;&#1089;&#1090;&#1086;&#1090;&#1099; &#1087;&#1088;&#1077;&#1076;&#1089;&#1090;&#1072;&#1074;&#1083;&#1077;&#1085;&#1099; &#1083;&#1080;&#1096;&#1100; &#1085;&#1072;&#1080;&#1073;&#1086;&#1083;&#1077;&#1077; &#1095;&#1072;&#1089;&#1090;&#1086; &#1080;&#1089;&#1087;&#1086;&#1083;&#1100;&#1079;&#1091;&#1077;&#1084;&#1099;&#1077; &#1074;&#1086;&#1079;&#1084;&#1086;&#1078;&#1085;&#1086;&#1089;&#1090;&#1080;
&#1084;&#1086;&#1076;&#1091;&#1083;&#1077;&#1081;. &#1058;&#1077; &#1088;&#1072;&#1079;&#1088;&#1072;&#1073;&#1086;&#1090;&#1095;&#1080;&#1082;&#1080;, &#1082;&#1086;&#1090;&#1086;&#1088;&#1099;&#1077; &#1093;&#1086;&#1090;&#1103;&#1090; &#1079;&#1072;&#1085;&#1080;&#1084;&#1072;&#1090;&#1100;&#1089;&#1103; &#1089;&#1077;&#1088;&#1100;&#1105;&#1079;&#1085;&#1086;
&#1080;&#1089;&#1087;&#1086;&#1083;&#1100;&#1079;&#1086;&#1074;&#1072;&#1090;&#1100; Open APIs &#1076;&#1086;&#1083;&#1078;&#1085;&#1099; &#1090;&#1072;&#1082;&#1078;&#1077; &#1091;&#1089;&#1090;&#1072;&#1085;&#1086;&#1074;&#1080;&#1090;&#1100; &#1087;&#1086;&#1083;&#1085;&#1099;&#1081; &#1084;&#1086;&#1076;&#1091;&#1083;&#1100; &#1087;&#1086;&#1076;&#1076;&#1077;&#1088;&#1078;&#1082;&#1080;
Open API (API Support), &#1082;&#1086;&#1090;&#1086;&#1088;&#1099;&#1081; &#1087;&#1088;&#1077;&#1076;&#1086;&#1089;&#1090;&#1072;&#1074;&#1083;&#1103;&#1077;&#1090; &#1074;&#1089;&#1102; &#1088;&#1072;&#1089;&#1096;&#1080;&#1088;&#1077;&#1085;&#1085;&#1091;&#1102;
&#1092;&#1091;&#1085;&#1082;&#1094;&#1080;&#1086;&#1085;&#1072;&#1083;&#1100;&#1085;&#1086;&#1089;&#1090;&#1100;, &#1086;&#1090;&#1089;&#1091;&#1090;&#1089;&#1090;&#1074;&#1091;&#1102;&#1097;&#1091;&#1102; &#1074; &#1076;&#1072;&#1085;&#1085;&#1086;&#1084; &#1084;&#1086;&#1076;&#1091;&#1083;&#1077;, &#1072; &#1090;&#1072;&#1082;&#1078;&#1077; &#1089;&#1086;&#1076;&#1077;&#1088;&#1078;&#1080;&#1090;
&#1087;&#1086;&#1083;&#1085;&#1091;&#1102; &#1089;&#1087;&#1088;&#1072;&#1074;&#1082;&#1091; &#1087;&#1086; Open API."
  />
</module>

BTW there is no magic involved in finding these things. Try opening
the update XML files in the NetBeans editor and running standard XML
validation on them. You will see errors.
Comment 13 rbalada 2005-02-07 15:12:45 UTC
Is this still an issue? I don't see any L10N NBMs in actual catalog
(dev_1.8_.xml).

This issue is either already fixed or does not need any further fixes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo