Bug 32207 - focus problems with Versioning Explorer
focus problems with Versioning Explorer
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC All
: P3 (vote)
: TBD
Assigned To: Peter Zavadsky
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-22 01:21 UTC by Mikhail Romanov
Modified: 2008-12-23 11:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Romanov 2003-03-22 01:21:49 UTC
After calling some actions in Versioning Explorer,
which perform GUI operations in the IDE frame,
Versioning Explorer window retains the focus, but
mouse events are not properly dispatched/processed
in it after that.

How to reproduce:

1. Start IDE and mount CVS FS
2. Modify some file and call Versioning Explorer
for it
3. Call Diff Graphical action on one of the
revisions - notice that though diff window
appeared in the main IDE frame, window focus is
still owned by Versioning dialog
4. Try to call e.g. popup menu on some tree node
in Versioning dialog - notice that it doesn't work
properly without manual switching of widow focus
there and back.
Comment 1 Jiri Kovalsky 2003-03-22 09:04:30 UTC
Yes, confirming this as valid bug. Reproduced in #030321_1 build of
Sun ONE Studio 5.0. Workaround is to dock "Versioning Explorer" into
normal explorer of the IDE.
Comment 2 Martin Entlicher 2003-03-22 16:00:11 UTC
This is a general focus problem, not only with Versioning Explorer.
It's impossible to fix this in VCS modules, it must be handled in the
window system.
Comment 3 mslama 2003-03-24 10:54:09 UTC
Will be investigated, what OS, JDK?
Comment 4 Mikhail Romanov 2003-03-31 20:50:18 UTC
I tried it on Windows 2000 with JDK 1.4.0_02 and Linux RH 7.2 under
GNOME with JDK 1.4.1_02 (both JDKs are recommended ones for Nevada.
Comment 5 Marian Mirilovic 2003-11-26 12:57:04 UTC
Because Window System v1 will not be supported from now by our team, all old
winsys issues (now "core/window system v1" issues) are going to be closed as
WONTFIX. 

Changes in API which emerged both from UI spec 
and problems with adjusting to the older API are described in the document
http://core.netbeans.org/windowsystem/changes.html.
 It shows also recommends how the client code should be adjusted to the new
window system.

If you think this issue apply also to the new winsys then change the
subcomponent (to "core/window system") and REOPEN it.
Comment 6 Marian Mirilovic 2004-02-27 14:13:21 UTC
issue doesn't apply to new window system - verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo