Bug 32118 - New object name isn't selected when choosing "All Templates" from context menu
New object name isn't selected when choosing "All Templates" from context menu
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
3.x
All All
: P1 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-19 05:14 UTC by John Baker
Modified: 2008-12-23 11:24 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
a proposed patch (687 bytes, patch)
2003-04-04 13:24 UTC, Jiri Rechtacek
Details | Diff
binary patch to lib/patches (8.46 KB, application/octet-stream)
2003-04-04 13:27 UTC, Jiri Rechtacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Baker 2003-03-19 05:14:28 UTC
Using S1S, J2SE 1.4.0_03, Windows 2000

The templates differ in the 2nd screen if the 
File->New menu or New toolbar button is clicked
vs. 
Choosing New Templates context menu from the Explorer

The object name isn't selected when using the
context menu.

To reproduce:

1) In the Explorer, select a mounted filesystem
and open the context menu
2) Choose XML - XML document and click next
3) The textedit is not selected

The user needs to either delete the <default name>
or double-click to select it just to type the
name of an object in.

This is a regression from previous releases.
I notice that if the preset object is chosen
(when right-click on filesystem in Explorer and choose
New the 2nd set of submenu items
 such as 
Folder
Java Package, 
Java Main Class
Java Class
JFrame Form
 this feature is working
Comment 1 Jesse Glick 2003-03-19 05:18:11 UTC
I think you got the wrong component. Use 'core' if you are not sure
where to file something.
Comment 2 Jiri Rechtacek 2003-03-19 15:30:57 UTC
I'm investigating it.
Comment 3 Marian Mirilovic 2003-03-19 16:02:14 UTC
It's not regression, because this feature is new in release35 !
Comment 4 Jiri Rechtacek 2003-03-19 16:26:36 UTC
There is a problem with focus in NewObjectPanel but not regression, a
possibility invoke Template Chooser panel (1st panel) is new in nb3.5.
  If an user use a template from offer templates, the focus is gained
correctly. Workaround is use TemplateWizard from File->New menu (or
Ctrl+N). However is should be fixed ASAP.
Comment 5 Jiri Rechtacek 2003-03-19 16:50:49 UTC
fixed in maintrunk
Revision  Path
1.6       openide/src/org/openide/loaders/NewObjectPanel.java
Comment 6 pzajac 2003-03-24 13:30:48 UTC
verified in 200303240100, linux
Comment 7 John Baker 2003-04-03 02:57:02 UTC
I'm still seeing this bug using Studio kit 030401 on Linux
and Solaris.

Comment 8 Jiri Rechtacek 2003-04-03 09:06:49 UTC
John, fix of this issue was integrated in main trunk (by Target
Milestone value). S1S Studio is built on netbean's release35 branch in
present time, so the fix won't work in current release S1S but in next
one. I close as fixed.
Comment 9 Marian Mirilovic 2003-04-03 09:36:35 UTC
verified again
Comment 10 John Baker 2003-04-03 22:27:45 UTC

This is a regression and had been entered as a P1 so it should
be integrated in the 3.5 branch.  What's the rationale for not
integrating this ?
Comment 11 _ ttran 2003-04-04 07:17:12 UTC
Our QA engineer, Marian Mirilovic identified this issue is not a
regression.  See his comment entered Mar/19 in this bug report
Comment 12 Jan Chalupa 2003-04-04 11:04:43 UTC
I don't want to go into discussions whether this is a regression or
not. The current behavior in the recent 3.5/S1S builds is inconsistent
and annoying.

Since the fix is available and already verified by QA, I think it
should be integrated into release35 asap.


Comment 13 _ ttran 2003-04-04 11:48:39 UTC
I don't mind calling this bug P1 either.  If ppl think we should fix
it in 3.5, then fine.

Jiri, please prepare the patch/diff and send request
Comment 14 Marian Mirilovic 2003-04-04 12:37:21 UTC
Fix works for me on Sol8/CDE , but it seems like doesn't work on Lin/RH7.
Comment 15 Jiri Rechtacek 2003-04-04 13:22:11 UTC
The fix were working on Linux too before Datasystems separation. I
prepare diff and binary patch to be integrated to release35.
Comment 16 Jiri Rechtacek 2003-04-04 13:24:35 UTC
Created attachment 9706 [details]
a proposed patch
Comment 17 Jiri Rechtacek 2003-04-04 13:27:23 UTC
Created attachment 9707 [details]
binary patch to lib/patches
Comment 18 Marian Mirilovic 2003-04-04 14:16:18 UTC
patch verified
Comment 19 Marian Mirilovic 2003-04-04 14:16:48 UTC
fixed
Comment 20 Peter Zavadsky 2003-04-04 14:24:34 UTC
I reviewed the patch.

It is a hack which works just for the case, the parent component is
already shown on screen (which is this case), it wouldn't work it the
parent is not shown yet.
On the other hand it is safe and there doesn't seem to be another nice
solution.
Comment 21 _ ttran 2003-04-04 14:31:03 UTC
approved for 3.5 
Comment 22 Jiri Rechtacek 2003-04-04 14:35:32 UTC
Fix is integrated to release35 branch.
Comment 23 Marian Mirilovic 2003-04-07 09:54:39 UTC
verified in [nb3.5](200304062350)
Comment 24 John Baker 2003-04-07 23:06:00 UTC
Fix verified in Studio, kit 030306.
Thank you!!!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo