Bug 32080 - [2004-04-14] Wrong layout of files in distribution
[2004-04-14] Wrong layout of files in distribution
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
4.x
PC All
: P2 (vote)
: 4.x
Assigned To: Jaroslav Tulach
issues@platform
tcr, core-promod
: ARCH
Depends on: 20052 35900 41621 45467
Blocks: 36663
  Show dependency treegraph
 
Reported: 2003-03-18 12:41 UTC by Jaroslav Tulach
Modified: 2008-12-22 20:33 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
cvs diff -r buildsys_last_known_good_trunk_before_merge -r clusters_32080_without_smart_installer (50.06 KB, patch)
2004-03-19 15:18 UTC, Jaroslav Tulach
Details | Diff
The diff against today's trunk (32.72 KB, patch)
2004-03-29 12:24 UTC, Jaroslav Tulach
Details | Diff
Commit log from the merge (16.55 KB, patch)
2004-04-14 10:17 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2003-03-18 12:41:53 UTC
> q: bad file layout: eg. /bin directory should
contain only runable
> files, /lib should called /share because the
libraries are platform
> independent; you should become familiar with
recommended layout on
> solaris and be compliant with it

We should likely keep as same format as possible
on all platforms, I guess.

> q: ide.config is too generic name; you should
use something more
> specific, like netbeans.config or so
> (this is probably going to be a TCR)

Or it is too concrete - platform is not IDE.
Comment 1 Jesse Glick 2003-03-18 12:51:01 UTC
Re. first part - I think only the location of ide.cfg needs to change
in the normal NetBeans packaging scheme. Otherwise, native packages
can if they wish rearrange things to some weird layout using share/
for everything, but this would be quite unnatural for a plain ZIP/TAR
archived install.

Re. second part - already filed separately, pls. ignore.
Comment 2 Jesse Glick 2003-05-10 16:03:04 UTC
BTW a user request - the Xerces wrapper module, e.g., should not be
named xerces.jar. Should be named xerces-wrapper.jar or xerces-nb.jar
or something like that. Same for ant.jar, etc. Or just use NB code
names, e.g. org-apache-tools-ant-module-2-2.17.jar which would not be
confused with ant-1.5.1.jar.
Comment 3 Jaroslav Tulach 2004-03-15 13:55:01 UTC
I've started work on the new layout and cluster system as part of this
issue. I've created branch clusters_32080 rooted at
buildsys_last_known_good_trunk_before_merge, right now nbbuild, core,
openide, editor, utilities are branched, so to get the branch use

cvs co -r buildsys_last_known_good_trunk_before_merge standard
cvs upd -r clusters_32080 openide core nbbuild editor utilities

The whole NetBeans IDE seems to compile correctly and have the
expected layout, thanks Michal.
Comment 4 Jaroslav Tulach 2004-03-19 15:18:53 UTC
Created attachment 14057 [details]
cvs diff -r buildsys_last_known_good_trunk_before_merge -r clusters_32080_without_smart_installer
Comment 5 _ ttran 2004-03-26 15:41:34 UTC
the very first thing we should do now is to sync up this branch with
trunk. After substantinal changes caused by buildsys it's not a
trivial task
Comment 6 Jaroslav Tulach 2004-03-29 12:24:21 UTC
Created attachment 14185 [details]
The diff against today's trunk
Comment 7 Jaroslav Tulach 2004-03-29 12:26:02 UTC
New branch created for core, nbbuild and xtest modules named
layout_32080. Still works only on unix machines, but everything seems
to be good. Commit validation passes.
Comment 8 Jaroslav Tulach 2004-04-01 08:46:21 UTC
I've updated the branch to latest daily build and verified that it
builds. Use:

cvs co -r BLD200403311800 standard_nowww apisupport_nowww ide_nowww
cvs co -r layout_32080 core nbbuild xtest

Comment 9 _ ttran 2004-04-04 08:29:40 UTC
in the branch now

 * bin/netbeans
 * bin/netbeans.exe
 * bin/nb.exe
 * etc/netbeans.conf (used to be ide.cfg, I've changed the format)
 * platform4/launcher/nbexec.exe
 * platform4/launcher/nbexec
 * platform4/launcher/security.policy


Comment 10 Jaroslav Tulach 2004-04-05 13:35:04 UTC
Made uptodate with BLD200404041800. Use:

cvs co -r BLD200404041800 standard_nowww apisupport_nowww ide_nowww
cvs co -r layout_32080 core nbbuild xtest


Comment 11 Jaroslav Tulach 2004-04-08 10:30:30 UTC
Made uptodate with BLD200404071800. Use:

cvs co -r BLD200404071800 standard_nowww apisupport_nowww ide_nowww
jemmy jellytools
cvs co -r layout_32080 core nbbuild xtest
Comment 12 Jaroslav Tulach 2004-04-14 10:17:23 UTC
Created attachment 14381 [details]
Commit log from the merge
Comment 13 Jaroslav Tulach 2004-04-14 10:18:54 UTC
In trunk.
Comment 14 Marian Mirilovic 2004-08-11 10:28:25 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo