Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 31900 - Selection changed very slow
Selection changed very slow
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows ME/2000
: P3 (vote)
: TBD
Assigned To: _ tboudreau
issues@platform
: PERFORMANCE
Depends on: 29447
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-11 16:06 UTC by sva
Modified: 2008-12-23 10:58 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sva 2003-03-11 16:06:24 UTC
This bug is created in addition for bug 31733.

Steps to reproduce:
1. Open generated servlet for JSP file.
2. Select some variable and press Ctrl+1 to see properties 
view.
3. Click twice on method name.
4. Click twice on variable again.

Result: Properties window updated only after ~ 1,5 - 2 
seconds. I think it's too slow.

Reproduced with build 030311 under W2k.
I have following configuration: P-IV 1800 Mhz, 512 RAM.
Comment 1 Martin Roskanin 2003-03-11 16:25:54 UTC
Properties windows should be implemented somewhere in openide/core.
Reassigning.
Comment 2 Marian Mirilovic 2003-03-12 14:32:05 UTC
Reassigne to Tim for evaluation.
Comment 3 _ tboudreau 2003-03-12 18:18:13 UTC
Some additional delaying was added to property sheet recently as
a performance optimization (so keyboard navigation in explorer -
as in holding down the down arrow) isn't slow and choppy because
the property sheet is rebuilding its component tree hundreds of
times.

With the property sheet rewrite, the infrastructure will be much
more lightweight, offering, ideally, almost no object creation to 
update the sheet.  Thus it will probably be possible to reduce the
delay without incurring overhead - far less work will be done to
display the properties of a node.

There is also the matter that the nodes in question may do
inordinate work to build their property sets - I don't know.
Comment 4 David Simonek 2003-03-20 17:52:20 UTC
Scheduling for 4.0. Also ccing Jiri Rechtacek, who made related
changes in prop sheet code. Thx.
Comment 5 _ tboudreau 2003-07-16 20:01:16 UTC
Fixed - property sheet rewrite integrated.  IMO the 
the timing values for this are reasonable, and performance
should be a little better with the new property sheet.
Comment 6 sva 2003-07-17 14:25:40 UTC
Reopen. The same situation with new property sheet.
Comment 7 _ tboudreau 2003-07-17 16:46:44 UTC
Cc'ing Jano from the UI team, changing category to UI.

The delay in changing the property sheet to display the new node
is *by design* - it is intentional.  The reason:  If the user
is rapidly navigating either a file (the selected node changes
every time the caret enters a new method) or when the user is
rapidly navigating in a tree (again, holding down the up arrow
or something such), performance is degraded if the property sheet
is repainting many times per-second.

The timings can be changed, and it may be that with the new property
sheet, which is lighter-weight, we can probably speed it up a bit.
Please discuss this with the UI folks regarding appropriate 
timings.  Bear in mind that some compromise is necessary
for performance.
Comment 8 _ tboudreau 2003-09-09 02:03:57 UTC
I've reduced the secondary delay from 350ms to 150ms.  Hopefully 
that will satisfy :-)
Comment 9 _ tboudreau 2003-09-09 02:19:36 UTC
C:\space\nb_all\openide\src\org\openide\explorer\propertysheet>cvs 
commit Proper
tySheet.java
Checking in PropertySheet.java;
/cvs/openide/src/org/openide/explorer/propertysheet/PropertySheet.jav
a,v  <--  P
ropertySheet.java
new revision: 1.123; previous revision: 1.122
done
Processing log script arguments...
Mailing the commit message to cvs@openide.netbeans.org (from 
tboudreau@netbeans.
org)
Comment 10 Marian Mirilovic 2004-06-30 11:11:45 UTC
verified in [nb_dev](200406291800)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo