Bug 31842 - Custom editor button not displayed for property editors if getAsText=null, isPaintable=true, supportsCustomEditor=true
Custom editor button not displayed for property editors if getAsText=null, is...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
All All
: P3 (vote)
: TBD
Assigned To: _ tboudreau
issues@platform
s1s
: A11Y, FOCUS
Depends on: 29447
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-10 21:57 UTC by Unknown
Modified: 2008-12-23 10:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2003-03-10 21:57:12 UTC
Description: 


Name: ssR10187			Date: 01/29/2003


build 030123 of Nevada

Steps to reproduce:
1. Create  "Session EJB" (or any other  EJB)  from the New Wizard window.
2. Open the "Properties of Session" window, tab to the Properties pane.

#1.  Focus disappears in the window after entering a new name in the textfield.
- tab to the "Name" sheetbutton, push <space bar>
- in the textfield enter the new name
- push <Enter>
The new name has been entered but focus disappears, the key <Tab> does not work.

#2.  Focus disappears after selecting combo. 
- tab to the "Bean Type" sheetbutton, default value is "Stateless"
- push <space bar>
- in combo push the <Down> arrow key and select "Statefull"
- push <Enter>
The new value has been selected but focus disappears, the key <Tab> does not
work.

#3.  Ellipsis disappears after pressing space.
- tab to the sheetbutton "Sec Identify" and press <space bar> or <Enter>.
   Ellipsis appears and immediately disappears,  you cannot call the property
editor. 
   See also bug4805655, it exists in Nevada release too.
   
These tree problems exist for all other panes  (References, Sun One As,
Weblogic7, J2EE, WebLogic) 
and it is very hard to use properties for editing or changing.
======================================================================

Evaluation: 
I cannot reproduce #1 or #2. 

For #3, this would seem to be a generic prop sheet problem since
we don't control the UI at all. In this case, the property editor
paints the value, so perhaps the openide code wasn't tested for
this scenario. Basically:

* getAsText returns false
* isPaintable returns true
* paintValue actually paints the value
* supportsCustomEditor returns true.

xxx@xxxx 2003-03-10

A comment.
Comment 1 Marian Mirilovic 2003-03-11 09:26:06 UTC
[s1s5](030306), [jdk1.4.1](01)

#1 - worksforme
#2 - worksforme
#3 - reproducible
Comment 2 _ tboudreau 2003-03-11 15:31:14 UTC
The problem is that the default inplace
editor panics at getAsText returning null.  I reproduced this,
creating a property editor with the described characteristics.

This will work with the property sheet rewrite (the custom editor
button will always be visible and focusable.  I should make a note
here that in the case getAsText returns null, the new sheet should
default that to opening the custom editor).

Workaround 1:  Return "" or something from getAsText - you can 
always ignore it in setAsText.

Workaround 2:  Supply a custom inplace editor via hinting so the
property sheet has some valid editor to instantiate (this could
just be JComponent that overrides paint () and delegates to the
property editor's paint method, so the appearance is consistent
and the code is in one place.

Workaround 3:  If there's something useful you could return from
getTags() that would also solve the problem.
Comment 3 _ tboudreau 2003-03-11 15:34:40 UTC
Sorry, missed the 7 key in the blocks field.
Comment 4 David Simonek 2003-03-20 17:48:06 UTC
Moving to 4.0, will be fixed as Tim said, along with the rewrite.

Joe, question for you - did suggested workarounds work for you? Is it
enough for you now in 3.5 timeframe or is it a stopper?
Comment 5 _ tboudreau 2003-07-16 19:56:40 UTC
Property sheet rewrite integrated.  Tested this with a custom
node & property.  It works correctly.
Comment 6 Lukas Hasik 2003-12-10 16:03:43 UTC
200312091900


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo