Bug 31748 - Focus is not returned to editor when closing editor
Focus is not returned to editor when closing editor
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows ME/2000
: P3 (vote)
: 3.x
Assigned To: mslama
issues@platform
: FOCUS
: 33585 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-06 14:35 UTC by Martin Roskanin
Modified: 2008-12-23 09:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Roskanin 2003-03-06 14:35:07 UTC
Open several files in editor. Close one of them.
The editor stay focused but the caret is lost -
the editor doesn't receive focus gained event.
Comment 1 mslama 2003-03-14 10:55:01 UTC
I investigated: When I close editor using Ctrl-F4 newly activated
TopComponent (another editor) does not receive FOCUS_GAINED event on
JDK 1.4.1_01 even if requestFocus() is called on activated
TopComponent. I asked AWT team and they say it is issue #4648816. It
is fixed already in JDK 1.4.2_b18 so I suggest to close this issue. (I
checked and it works fine.)
Comment 2 Martin Roskanin 2003-07-10 15:42:55 UTC
*** Issue 33585 has been marked as a duplicate of this issue. ***
Comment 3 Marian Mirilovic 2003-07-28 16:22:26 UTC
Marek is right - verifying, closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo