Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 31552 - Deadlock when running projects/compilation tests
Deadlock when running projects/compilation tests
Status: CLOSED DUPLICATE of bug 30950
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
3.x
PC All
: P2 (vote)
: 3.x
Assigned To: issues@projects
issues@projects
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-27 22:17 UTC by Vitezslav Stejskal
Modified: 2003-12-11 14:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
full thread dump (11.95 KB, text/plain)
2003-02-27 22:25 UTC, Vitezslav Stejskal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitezslav Stejskal 2003-02-27 22:17:31 UTC
There is a deadlock when running tests for
projects/compilation module, it seems to occure
under both jdk 1.3.1_02 and 1.4.1. It seems it is
caused by synchronization in
ProjectMember$Evnironment class.

The threads in deadlock are the 'FolderRecognizer'
(as usually) and 'ContainersList-Updater'. The
'FolderRcognizer' thread creates BTDataObject
which creates the ProjectMember for itself in its
ctor, but the 'ContainersList-Updater' tries to
access Lookup of another PM which keeps the lock
and indirectly asks some DataFolder for its children.

Several bad things happend at the same time:
1. BTDataObject does something in its ctor, this
should be avouded (especially calls to another
'higher' layer; the projects in this case)

2. ProjectMember$Environment performs wrong
synchronization in beforeLookup method, this is
probably the root cause.

3. The core/naming (DOEnum) uses DataSystems
(DataFolder.getChildren) to get the list of
bidings in the Context. It's unnecessary and it's
done this way just for the files ordering.
Comment 1 Vitezslav Stejskal 2003-02-27 22:25:39 UTC
Created attachment 9203 [details]
full thread dump
Comment 2 David Konecny 2003-02-28 10:39:58 UTC
ad #3 - already filed as issue 30632. I added your comment there for
the record.
Comment 3 Dusan Balek 2003-07-23 15:55:44 UTC
Studying attached thread dump, this deadlock seems to be the same as
the one described in #30950

*** This issue has been marked as a duplicate of 30950 ***
Comment 4 Jan Becicka 2003-11-25 14:00:45 UTC
As described in
http://www.netbeans.org/servlets/ReadMsg?msgId=619519&listName=nbdiscuss the
current work on projects prototype has been stopped.

Marking issue as VERIFIED --->
Comment 5 Jan Becicka 2003-11-25 14:09:23 UTC
---> CLOSED


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo