Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 31456 - Keyboard nav/edit of TreeTableView
Keyboard nav/edit of TreeTableView
Status: CLOSED DUPLICATE of bug 29612
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows ME/2000
: P2 (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-25 19:03 UTC by Chris Ledantec
Modified: 2008-12-22 15:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Ledantec 2003-02-25 19:03:20 UTC
i can move up and down in the list with the arrows
(though it's not the fastest to respond to a
key-press) and i can tab across rows but:

-there is no focus indication (blue box) on the
name column so it looks like focus is in lala land.

-no cells are editable by the keyboard. i would
expect being able to press the space bar on a cell
to be able to edit it like i can in the property
sheet.

i would also suggest making the Done column
check-boxes without the yes/no text as the text
suggests that if it isn't finished i should click
the box when the no label is shown and if it is
finished i should check the box when the yes label
is there -this is backwards. the check-boxes
should also respond simply to a spacebar input to
check/uncheck.
Comment 1 Torbjorn Norbye 2003-02-26 04:07:12 UTC
I think the focus indication and cell-editability problems are general
treetableview problems - the same problems should be there in the
debugger. 

I agree that the checkbox alone is enough in the Done column.
Comment 2 Chris Ledantec 2003-02-26 08:35:30 UTC
the debugger has a similar problem but this was fixed in the xml tree
editor 

'open' an xml file, in navigate to an element and you'll see names and
values in the two column table in the left pane. once in the table tab
takes focus through the cells with clear indication where it is and
space begins editing the cell with focus. Petr Kuzel worked on this so
he might be able to help.
Comment 3 Tim Lebedkov 2003-02-26 09:39:30 UTC
I don't think yes/no text should be removed. If you don't 
like it just make the column as narrow so you don't see 
the text.

My XML editor shows attributes/values in the right panel 
in a table not in a TreeTableView
Comment 4 Chris Ledantec 2003-02-26 10:05:58 UTC
oops. you're right, i was looking at a treetable not a table. this may
not be fixable.

the problem with the yes/no text is the way the ui reads: the done
column asks a a question, 'Are you Done with this task?' and the
checkboxes provide the way to answer. the label for the checkbox tells
the user what kind of answer to give. combining the two labels gives
to different questions/answers:

[] no I am not Done with this task
[] yes I am Done with this task

each by itself is okay but checking the box essentially changes the
question from negative to affirmative and it becomes confusing. 

the meaning of the question and checkbox state is this:

[]I am done with this task

the task list breaks up this questions but puting the label in the
column header (shortened to Done[?]) and the checkbox in each row
where the answer to the question applies.
Comment 5 Tim Lebedkov 2003-02-26 10:43:16 UTC
2:1

I will remove "yes/no".
Comment 6 Torbjorn Norbye 2003-03-02 01:01:51 UTC
The third issue (no "Yes/No" strings in the Done column) has been fixed.

The first two issues (no focus feedback, no edit-activation shortcut)
are remaining, and these are generic TreeTableView bugs. Transferring
to openide.
Comment 7 Jiri Rechtacek 2003-03-03 09:06:25 UTC
ad.2. duplicate of 29612
ad.3. duplicate of 19266
I will file a task to work up the UI spec of TreeTableView (including
keyboard navigation, changing values etc.)

*** This issue has been marked as a duplicate of 29612 ***
Comment 8 Marian Mirilovic 2003-07-22 16:43:12 UTC
verified, closed - it's duplicate.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo