Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 31042 - Import Wizard shown on every startup if core-ide.jar present but core-deprecated.jar disabled
Import Wizard shown on every startup if core-ide.jar present but core-depreca...
Status: VERIFIED FIXED
Product: ide
Classification: Unclassified
Component: Import Settings
3.x
PC Linux
: P2 (vote)
: 3.x
Assigned To: David Konecny
issues@platform
:
: 31999 (view as bug list)
Depends on:
Blocks: 19443
  Show dependency treegraph
 
Reported: 2003-02-13 20:06 UTC by Jesse Glick
Modified: 2008-12-22 21:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-02-13 20:06:21 UTC
$userdir/system/project.last is never created -
only NbProjectOperation in core-deprecated.jar
would create it. Assuming that more and more
modules remove deps on openide-deprecated.jar, if
*all* of them do, this bug will affect the regular
IDE. Currently it only affects reduced module
configs - those which do not use
openide-deprecated.jar.
Comment 1 Jesse Glick 2003-02-13 20:08:13 UTC
Please use some other signal that the wizard has been shown before -
e.g. continue to check project.last (for compat with older user dirs),
but if the wizard is closed (except by Cancel) then write out a
special file to the userdir (or system filesystem) used just by the
import wizard.
Comment 2 David Konecny 2003-03-13 15:46:19 UTC
Fixed in trunk:
Checking in src/org/netbeans/core/upgrade/UpgradeWizard.java
new revision: 1.7; previous revision: 1.6

If you think it is OK I will integrate it into NB35.
Comment 3 David Konecny 2003-03-14 09:55:19 UTC
*** Issue 31999 has been marked as a duplicate of this issue. ***
Comment 4 David Konecny 2003-03-14 09:57:09 UTC
This is serious issue for platform. Must be fixed in NB35.
Comment 5 David Konecny 2003-03-14 09:59:37 UTC
Fixed in NB35:
Checking in src/org/netbeans/core/upgrade/UpgradeWizard.java
new revision: 1.6.2.1; previous revision: 1.6
Comment 6 pzajac 2003-03-14 12:50:35 UTC
verified in trunk. 
Comment 7 pzajac 2003-03-27 10:01:06 UTC
verified in nb35


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo