Bug 31006 - FilterNode should delegate getValue(<atribute>) to original node
FilterNode should delegate getValue(<atribute>) to original node
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Nodes
3.x
All All
: P3 (vote)
: 3.x
Assigned To: Petr Nejedly
issues@platform
: API
: 40022 (view as bug list)
Depends on:
Blocks: 9940 39870
  Show dependency treegraph
 
Reported: 2003-02-12 17:32 UTC by Jiri Rechtacek
Modified: 2008-12-22 20:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2003-02-12 17:32:10 UTC
FilterNode doesn't delegate
getValue(String attributeName) to original node, I
think setValue should be delegated also.
Comment 1 Petr Hrebejk 2003-02-20 10:22:24 UTC
As the Node extends FeatureDescriptor it seems reasonable add the
delegation of FeatureDescriptor methods into FilterNode.
Comment 2 Petr Nejedly 2004-01-09 09:44:38 UTC
Taking over the node bugs from phrebejk.
Comment 3 Petr Nejedly 2004-02-04 09:47:33 UTC
It is not that simple. If the get/setValue delegation is enabled,
should I delegate the call for all keys? It also means API change.
OK, let's try the FastTrack process ;-)
Comment 4 Petr Nejedly 2004-02-12 15:18:52 UTC
*** Issue 40022 has been marked as a duplicate of this issue. ***
Comment 5 Petr Nejedly 2004-02-13 15:12:02 UTC
Implemented, with tests and apichanges notice.

openide/src/org/openide/nodes/FilterNode.java,v1.87
openide/test/unit/src/org/openide/nodes/FilterNodeTest.java,v1.13
openide/openide-spec-vers.properties,v1.133
openide/api/doc/changes/apichanges.xml,v1.186
Comment 6 Jaroslav Tulach 2004-02-13 15:25:26 UTC
Nice.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo