Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 31002 - TreeTableView does not visually indicate KB focus
TreeTableView does not visually indicate KB focus
Status: CLOSED DUPLICATE of bug 29612
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Linux
: P4 (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
: A11Y, UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-12 16:44 UTC by Jesse Glick
Modified: 2008-12-22 20:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-02-12 16:44:10 UTC
[dev feb 11] In the Explorer (a BeanTreeView),
when you have a node selected, but the Explorer
does not have KB focus, the node label is just
shaded light blue (Java L&F). When it has focus, a
slightly darker border is drawn around that; this
visually indicates the focus and is a very
valuable feedback indicator for KB users. But
TreeTableView shows only the borderless
highlighting, even when it has KB focus (in the
tree portion, that is). This is disconcerting and
makes KB navigation harder. It should show the
border when the tree part of the view has focus
(not the property parts of course - those already
have their own focus borders).
Comment 1 Jiri Rechtacek 2003-02-25 15:08:10 UTC

*** This issue has been marked as a duplicate of 29612 ***
Comment 2 Jiri Rechtacek 2003-02-25 15:11:08 UTC
*** Issue 24718 has been marked as a duplicate of this issue. ***
Comment 3 Marian Mirilovic 2003-07-22 10:13:28 UTC
verified, closed - it's duplicate.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo