Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 30950 - Deadlock in ProjectMemberList
Deadlock in ProjectMemberList
Status: CLOSED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
3.x
PC Windows ME/2000
: P2 (vote)
: 3.x
Assigned To: issues@projects
issues@projects
: THREAD
: 31527 31552 32252 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-11 14:09 UTC by Jan Pokorsky
Modified: 2004-04-19 16:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (14.71 KB, text/plain)
2003-02-11 14:11 UTC, Jan Pokorsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Pokorsky 2003-02-11 14:09:06 UTC
[jdk1.4.0-b92, my build 200302101417]

When I choose to create a basic java project on
Projects node a deadlock sometimes occurs in
ProjectMemberList.getProjectMember.
Comment 1 Jan Pokorsky 2003-02-11 14:11:32 UTC
Created attachment 8896 [details]
thread dump
Comment 2 Dusan Balek 2003-07-23 15:52:18 UTC
*** Issue 31527 has been marked as a duplicate of this issue. ***
Comment 3 Dusan Balek 2003-07-23 15:55:43 UTC
*** Issue 31552 has been marked as a duplicate of this issue. ***
Comment 4 Dusan Balek 2003-07-23 16:04:40 UTC
*** Issue 32252 has been marked as a duplicate of this issue. ***
Comment 5 Dusan Balek 2003-08-05 08:52:36 UTC
ProjectMemberList's synchronization model changed. Please, reopen if it appears
again.
Comment 6 Jan Becicka 2003-08-21 15:31:12 UTC
Verified
Comment 7 Jan Becicka 2003-11-25 14:21:40 UTC
As described in
http://www.netbeans.org/servlets/ReadMsg?msgId=619519&listName=nbdiscuss the
current work on projects prototype has been stopped.

Marking issue as CLOSED.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo