Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 30632 - eliminate dependency on current DataSystems
eliminate dependency on current DataSystems
Status: RESOLVED WONTFIX
Product: contrib
Classification: Unclassified
Component: Naming
3.x
All All
: P3 (vote)
: TBD
Assigned To: issues@contrib
issues@contrib
http://www.netbeans.org/servlets/Read...
:
Depends on: 30633
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-04 09:43 UTC by David Konecny
Modified: 2009-09-18 20:29 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Konecny 2003-02-04 09:43:15 UTC
action item from the summary of naming discussion:

* eliminate (as much as possible) dependency on
current DS and replace it with dependency on
core/settings module
Comment 1 David Konecny 2003-02-27 15:31:05 UTC
planned for 4.0
Comment 2 David Konecny 2003-02-28 10:38:30 UTC
comment from issue 31552:

> 3. The core/naming (DOEnum) uses DataSystems
> (DataFolder.getChildren) to get the list of
> bidings in the Context. It's unnecessary and it's
> done this way just for the files ordering.

issue to consider:
* should the naming sort objects returned from listBindings or not?
decision must be documented for clients.
Comment 3 David Konecny 2003-10-02 12:51:18 UTC
obsolete.

*** This issue has been marked as a duplicate of 35050 ***
Comment 4 David Konecny 2003-10-02 12:54:41 UTC
I thought that this was openide/settings issue.
Comment 5 Jiri Prox 2007-09-17 20:08:10 UTC
Obsolete milestone, please reevaluate
Comment 6 Jesse Glick 2009-09-18 20:29:07 UTC
Dead module.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo