Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 30434 - Compile status icons not updating appropriately
Compile status icons not updating appropriately
Status: CLOSED DUPLICATE of bug 30408
Product: platform
Classification: Unclassified
Component: Window System
3.x
All All
: P4 (vote)
: 3.x
Assigned To: mslama
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-28 16:32 UTC by dnoyeB
Modified: 2008-12-22 17:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
after first compile (14.85 KB, image/jpeg)
2003-01-28 16:33 UTC, dnoyeB
Details
after 2nd compile (25.84 KB, image/jpeg)
2003-01-28 16:34 UTC, dnoyeB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dnoyeB 2003-01-28 16:32:57 UTC
The compile status icon shows the needs compile
icon even after the file has been compiled.  If I
push compile a 2nd time, then the icon disappears.

Hmm, I  knew there was something funny.  This only
happens if the file is not showing in the
Explorer.  If the file is visible in the explorer
then the icon gets updated.  If its not, then the
icon does not get updated.  For instance, if you
have several files open in the source editor, but
their associated nodes are not shown in the
Explorer, then the tabs in the source editor will
still show the need for compile.

The 2nd compile causes their status icons to be
updated.  So whatever happens on the 2nd compile,
needs to happen on the first.

I put this at p4 because I dont see any other
problems related to it so far.

w2k, jdk1.3.1_06, WindowsLookAndFeel, NB3.4.1,
256MBRam, ~pII366
Comment 1 dnoyeB 2003-01-28 16:33:42 UTC
Created attachment 8700 [details]
after first compile
Comment 2 dnoyeB 2003-01-28 16:34:26 UTC
Created attachment 8701 [details]
after 2nd compile
Comment 3 dnoyeB 2003-01-29 15:01:00 UTC
I also noticed that the icon does not update till the jtree is shown.
 I hope this is not an indication that an event is required from the
jtree to update compile status as opposed to an event from the
'compiler' or some other more directly related source.  Seems a bit
lazy.  Furthermore with all the issues I have seen in my 2 months
using NB with WindowsLookAndFeel, I hesitate to tie anything to a
responce from a Swing Component, when possible of course.
Comment 4 dnoyeB 2003-01-31 16:20:24 UTC
probably related to issue #29623
Comment 5 dnoyeB 2003-02-11 15:10:52 UTC

*** This issue has been marked as a duplicate of 30408 ***
Comment 6 Marian Mirilovic 2003-07-22 15:39:48 UTC
verified, closed - it's duplicate.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo