Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 30216 - Support for Summary panel in new wizard framework
Support for Summary panel in new wizard framework
Status: RESOLVED DUPLICATE of bug 54908
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
3.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
: API, UI
: 54909 (view as bug list)
Depends on: 26552
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-20 08:43 UTC by akemr
Modified: 2008-12-22 10:15 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description akemr 2003-01-20 08:43:24 UTC
In new planned wizard framework, could it be
possible to support last Summary panel to solve
following use case?

Use case:
1. User works through the web module wizard.
2. At any point, they may click the Finish button.
3. The wizard window *should not close*, but
should display the Summary page which describes
what has been generated for them. This last panel
have to not display "Finish" or "Back" buttons,
only Close
4. Clicking the "Close" button on the summary
panel will close the Wizard window.

Jeff Hoffman wrote:
> the Summary panel should be displayed after the
Finish 
button has been clicked.  According to the Java
Look and Feel Design Guidelines: Advanced Topics
(see 
http://java.sun.com/products/jlf/at/book/Wizards5.html#51644),
the Summary page should appear in the Wizard
window with only the Close button.
Comment 1 Petr Jiricka 2003-04-18 15:12:41 UTC
I suggest the following solution:

Create a new interface WizardDescriptor.SummaryPanel:

    /** A special interface for panels which are the
    * last panel in the sequence and want to have the 
    * Close button instead of Previous/Next/Finish
    * The panel which precedes this panel must implement
    * the FinishBeforeSummaryPanel interface (see below)
    */
    public interface SummaryPanel extends Panel {
    }

Also create a new interface FinishBeforeSummaryPanel:

    /* A panel which is the last before the Summary panel.
     * The successor panel (if there is one) must implement
     * SummaryPanel.
     */
    public interface SummaryPanel extends FinishPanel {
    }

The wizard infrastructure behavior will change as follows:

- a panel which implements FinishBeforeSummaryPanel will 
have the Finish button enabled, and the Next button 
disabled.

- a panel which implements SummaryPanel will have only the 
Close button (and no other buttons).

Comment 2 Jiri Rechtacek 2005-02-14 09:03:54 UTC
*** Issue 54909 has been marked as a duplicate of this issue. ***
Comment 3 Jiri Rechtacek 2008-10-16 15:13:06 UTC

*** This issue has been marked as a duplicate of 54908 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo