Bug 29875 - Post install hook doesn't work with a space in userdir path
Post install hook doesn't work with a space in userdir path
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
-S1S-
PC Windows ME/2000
: P2 (vote)
: TBD
Assigned To: Petr Hrebejk
issues@platform
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-08 15:32 UTC by Martin Ryzl
Modified: 2003-09-17 12:44 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments
Suggested patch (1.51 KB, patch)
2003-01-08 16:02 UTC, Martin Ryzl
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Ryzl 2003-01-08 15:32:03 UTC
Autoupdate module allows to execute a post install
code. The code is specified in
main/main.properties file in the nbm. The command
consists of:
- java process - created by autoupdate module
- classpath - additioanl classpath may be
specified by nbm
- nbm parameters - specified by the nbm
- main class - specified by the nbm

There are keywords that can be replaced by the
module, for example %IDE_USER%. It is a question
whether it is nbm author's responsibility to quote
keywords, I think that it is.

However, the problem is with classpath - first
item of classpath is created by au module and _NOT
QUOTED_. So, if
userdir contains a space, the execution fails.

Tested on S1S 4.1, probably affects all versions
of NB and S1S.
Comment 1 Martin Ryzl 2003-01-08 16:02:44 UTC
Created attachment 8474 [details]
Suggested patch
Comment 2 Martin Ryzl 2003-01-08 16:04:58 UTC
Attached path quotes only java process and first item in the
classpath. User parameters (those specified in main.properties) must
be quoted by nbm author. If this model is OK, it should be correctly
documented in the autoupdate module documentation.
Comment 3 akemr 2003-01-09 09:18:09 UTC
Thanks, Martin. Fixed in trunk.

Fix quotes only java process and whole classpath.
Documentation - I added your note to #26730.
Comment 4 Antonin Nebuzelsky 2003-02-25 18:35:03 UTC
This is also fixed and released in a patch for S1S4u1.
Comment 5 Martin Ryzl 2003-07-08 14:42:57 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo