Bug 29848 - Explorer can retain KB focus even when not selected window
Explorer can retain KB focus even when not selected window
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
All All
: P3 (vote)
: 3.x
Assigned To: mslama
issues@platform
: A11Y, FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-07 19:44 UTC by Jesse Glick
Modified: 2008-12-23 09:39 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-01-07 19:44:56 UTC
[dev jan 07, MDI] Start NB. Close welcome window.
Click on sampledir and Ctrl-0 to open new explorer
view window. Dock it into Editor mode. Click in
new Explorer (root = sampledir). Has focus; arrow
keys move in it. Press Ctrl-2. Filesystems
Explorer has focus and is selected. Press Ctrl-3.
New explorer window is selected acc. to background
color (and Explorer mode is not, according to
title bar color) yet KB focus is still in
Filesystems Explorer! Bordered blue selection
rectangle indicating KB focus is in Filesystems
Explorer. You need to click the mouse in the new
explorer to give it KB focus; you cannot give it
KB focus using the KB.
Comment 1 Peter Zavadsky 2003-01-29 12:29:33 UTC
It seems to be a problem when the focused TopComponent is
ExplorerPanel. When the second component is CloneableEditor it works fine.

Reason it works C-2 is that there is a workaround, see the fix in
issue #28757.

So now I don't know, how it should work.

Anyway, the focus management in winsys, is quite complicated to me.

I probably add similar hack to editro view action.

Comment 2 Peter Zavadsky 2003-01-29 12:35:37 UTC
It seems CloneableEditor works fine just because it overwrites
requestFocus, where it transfers the focus to the pane.

Well, probably the same should be done to ExplorerPanel, but I'm not
sure now, the focus policy in 1.3 and 1.4 is a bit different.
Comment 3 Peter Zavadsky 2003-01-29 13:31:39 UTC
Fixed in [trunk]

openide/src/org/openide/explorer/ExplorerPanel.java 1.39
core/src/org/netbeans/core/actions/ViewFilesystemsTabAction.java 1.3
core/src/org/netbeans/core/actions/ViewRuntimeTabAction.java 1.3
projects/src/org/netbeans/modules/projects/ViewProjectsTabAction.java 1.3


Note: I fixed it the way ExplorerPanel transfers the focus to the
default focusable component (the approach CloneableEditor uses).

Thus I removed the hacks from issue #28757. 


In sum: it needs to be really though out how the focus should be
handled in TopComponents propertly, our policy is changing from fix to
fix (like when the focusability was disabled) and doesn't seem to have
any understandable direction.
Comment 4 Marian Mirilovic 2003-02-03 13:49:05 UTC
verified in [nb_dev](20030203)
Comment 5 mslama 2003-02-06 12:00:04 UTC
Usage requestDefaultFocus() in ExplorerPanel causes issue #30758. I
think subclasses of ExplorerPanel should explicitly request focus on
their desired subcomponent (like eg.CloneableEditor does).
Comment 6 mslama 2003-02-06 14:37:16 UTC
I added requestFocus() to NbMainExplorer$ExplorerTab. Project should
also add the same to their tab (as I assume they also subclass
ExplorerPanel).

Modified:
core/src/org/netbeans/core/NbMainExplorer.java r.1.113
Comment 7 Jesse Glick 2003-02-12 16:40:43 UTC
Still broken in [dev feb 11] for Explorer vs. Options window: dock
Options into MDI frame. Make sure it has focus (click on it, make sure
arrow keys work). Press Ctrl-2. Select Window -> Options. Options
panel now has focus border (and Explorer [Filesystems] has grey title
bar) but Explorer still has KB focus (and thick border on selected node).
Comment 8 Jesse Glick 2003-04-07 16:08:13 UTC
Encountered again in [dev 030402]. Click on some folder in
Filesystems. Press Ctrl-F to open search dialog. Type in some text
that will get at least one match. Search Results open. If not already
in desktop pane, select Window -> Frame Resides -> In IDE Desktop.
Click on some result file and double-click a result line. The Editor
window opens with focus at that line. Press Ctrl-F4 to close Editor.
Search Results still open but not focused or selected. Select Alt-W 3
to select Search Results. It is now selected (blue border in desktop
frame), but no focus. Press TAB a few times and you will see focus on
the unselected Explorer window. You can move around selection in the
Explorer (but property sheet does not update, etc.).

100% reproducible for me. You cannot give KB focus to the Search
Results dialog as far as I can tell.
Comment 9 Marian Mirilovic 2003-11-26 12:56:48 UTC
Because Window System v1 will not be supported from now by our team, all old
winsys issues (now "core/window system v1" issues) are going to be closed as
WONTFIX. 

Changes in API which emerged both from UI spec 
and problems with adjusting to the older API are described in the document
http://core.netbeans.org/windowsystem/changes.html.
 It shows also recommends how the client code should be adjusted to the new
window system.

If you think this issue apply also to the new winsys then change the
subcomponent (to "core/window system") and REOPEN it.
Comment 10 Marian Mirilovic 2004-02-27 14:13:09 UTC
issue doesn't apply to new window system - verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo