Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 29612 - [TTV] Keyboard focus not shown when it is in the first column of a tree table
[TTV] Keyboard focus not shown when it is in the first column of a tree table
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
All All
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
: A11Y, UI
: 24718 31002 31456 (view as bug list)
Depends on: 31896
Blocks: 31501 33281
  Show dependency treegraph
 
Reported: 2002-12-18 01:40 UTC by David-john Burrowes
Modified: 2008-12-22 18:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David-john Burrowes 2002-12-18 01:40:24 UTC
The keyboard focus indicator is not shown when the
focus is in the first column of a treetable, but
it is shown in other columns of the tree table.
Comment 1 Jiri Rechtacek 2003-02-25 15:08:06 UTC
*** Issue 31002 has been marked as a duplicate of this issue. ***
Comment 2 Jiri Rechtacek 2003-02-25 15:08:40 UTC
Phrased from issue 31002 (jglick):
[dev feb 11] In the Explorer (a BeanTreeView),
when you have a node selected, but the Explorer
does not have KB focus, the node label is just
shaded light blue (Java L&F). When it has focus, a
slightly darker border is drawn around that; this
visually indicates the focus and is a very
valuable feedback indicator for KB users. But
TreeTableView shows only the borderless
highlighting, even when it has KB focus (in the
tree portion, that is). This is disconcerting and
makes KB navigation harder. It should show the
border when the tree part of the view has focus
(not the property parts of course - those already
have their own focus borders).

Comment 3 Jiri Rechtacek 2003-03-03 09:06:24 UTC
*** Issue 31456 has been marked as a duplicate of this issue. ***
Comment 4 Marian Mirilovic 2003-07-22 10:07:53 UTC
*** Issue 24718 has been marked as a duplicate of this issue. ***
Comment 5 Jesse Glick 2003-10-17 21:13:21 UTC
See also comments in issue #18992 as to why that solves the practical
impact of issue #31002 though not the visual (aesthetic) impact.
Comment 6 _ tboudreau 2003-11-23 21:38:46 UTC
Fixed on property panel rewrite branch.
Comment 7 _ tboudreau 2003-12-09 09:37:00 UTC
Property panel rewrite branch merged.
Comment 8 Marian Mirilovic 2005-07-13 13:23:14 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo