Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 28962 - [TTV] pupup menu deselects nodes in TreeTableView
[TTV] pupup menu deselects nodes in TreeTableView
Status: VERIFIED DUPLICATE of bug 55553
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
All All
: P4 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks: 33281
  Show dependency treegraph
 
Reported: 2002-11-22 17:15 UTC by Tim Lebedkov
Modified: 2008-12-23 10:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
a hot fix (891 bytes, patch)
2002-12-05 19:25 UTC, Jiri Rechtacek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Lebedkov 2002-11-22 17:15:56 UTC
select multiple nodes in a TreeTableView,
right click on a node (but not on the node's text) 
all nodes but this one will be deselected
Comment 1 Jiri Rechtacek 2002-12-05 19:25:08 UTC
Created attachment 8186 [details]
a hot fix
Comment 2 Jiri Rechtacek 2002-12-05 19:31:01 UTC
I attached a fix (rather hotfix). The different mouse events are
processed as same way mutlitimes. I cut out the process an event on
mouseReleased and leave only on mousePressed. It should be tested.
Btw. this defect has minor impact at TTW usability, I decrease the
priority.
Comment 3 Jaromir Uhrik 2003-01-06 14:09:00 UTC
Version changed: 4.0 dev -> S1S 4.2
Comment 4 Jiri Rechtacek 2003-02-27 11:53:25 UTC
Because late phase of nb3.5 cycle, too risky to solve it now. It will
be solved in 4.0.
Comment 5 _ tboudreau 2003-12-08 18:04:21 UTC
FYI, I tried this hotfix to see if I could incorporate it on the
property panel rewrite branch.  Doesn't work anymore.
Comment 6 Stanislav Aubrecht 2005-03-10 09:30:47 UTC

*** This issue has been marked as a duplicate of 55553 ***
Comment 7 Tim Lebedkov 2005-03-27 13:06:08 UTC
ok


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo