Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 28862 - Add in-line error feature to API
Add in-line error feature to API
Status: RESOLVED DUPLICATE of bug 148730
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
3.x
All All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
http://ui.netbeans.org/docs/inline_er...
:
: 25209 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-19 21:30 UTC by Jan Benway
Modified: 2012-04-16 13:34 UTC (History)
8 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
web.xml editor (12.67 KB, image/jpeg)
2006-12-20 07:06 UTC, Milan Kuchtiak
Details
web.xml editor (edit Context Parameter) (12.08 KB, image/jpeg)
2006-12-20 07:07 UTC, Milan Kuchtiak
Details
web.xml editor (add Servlet) (16.37 KB, image/jpeg)
2006-12-20 07:08 UTC, Milan Kuchtiak
Details
web.xml editor (add Resource Reference) (17.24 KB, text/plain)
2006-12-20 07:09 UTC, Milan Kuchtiak
Details
Struts support (add Action) (28.95 KB, image/jpeg)
2006-12-20 07:09 UTC, Milan Kuchtiak
Details
Struts support (add Forward) (20.11 KB, image/jpeg)
2006-12-20 07:11 UTC, Milan Kuchtiak
Details
web.xml editor (add Resource Reference) (17.24 KB, image/jpeg)
2006-12-20 07:11 UTC, Milan Kuchtiak
Details
add cmp relationship (11.22 KB, image/png)
2006-12-20 08:52 UTC, Erno Mononen
Details
add select method (10.02 KB, image/png)
2006-12-20 08:57 UTC, Erno Mononen
Details
create data source (5.91 KB, image/png)
2006-12-20 14:53 UTC, Andrei Badea
Details
create java db database (11.24 KB, image/png)
2006-12-20 14:55 UTC, Andrei Badea
Details
Call EJB dialog validation (7.94 KB, image/png)
2006-12-20 17:11 UTC, Martin Adamek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Benway 2002-11-19 21:30:26 UTC
The inline error proposal at:
http://ui.netbeans.org/docs/inline_errors/index.html

Has been discussed at length on nbui and finalized.

Discussions are here:
http://www.netbeans.org/servlets/ReadMsg?msgId=383635&listName=nbui
http://www.netbeans.org/servlets/ReadMsg?msgId=404046&listName=nbui
Comment 1 Jan Benway 2002-12-16 22:44:21 UTC
*** Issue 25209 has been marked as a duplicate of this issue. ***
Comment 2 Jan Benway 2003-03-07 20:39:29 UTC
This has been partly implemented now, but only for wizards. See:
http://www.netbeans.org/issues/show_bug.cgi?id=28466

This issue should be kept open because it still needs to be
implemented for dialog boxes. The appearance (color, the invisible
text box border) should match what is implemented for wizards.
Comment 3 Antonin Nebuzelsky 2006-12-19 11:08:01 UTC
Unless several specific use cases in real dialog boxes are presented to us,
there is no point in doing a general API. Not planned now.
Comment 4 Radko Najman 2006-12-19 12:46:11 UTC
What about issue #90436? I think it is a quite clear use case generally related
to this issue.
Comment 5 Antonin Nebuzelsky 2006-12-19 14:44:15 UTC
> What about issue #90436?

See the comment at that issue. If that one is the specific case, let's continue
discussion in that issue.
Comment 6 Milan Kuchtiak 2006-12-20 07:05:38 UTC
In WeB/J2EE support we have plenty of use cases.
I will attach just few examples :
Comment 7 Milan Kuchtiak 2006-12-20 07:06:56 UTC
Created attachment 36822 [details]
web.xml editor
Comment 8 Milan Kuchtiak 2006-12-20 07:07:56 UTC
Created attachment 36823 [details]
web.xml editor (edit Context Parameter)
Comment 9 Milan Kuchtiak 2006-12-20 07:08:34 UTC
Created attachment 36824 [details]
web.xml editor (add Servlet)
Comment 10 Milan Kuchtiak 2006-12-20 07:09:05 UTC
Created attachment 36825 [details]
web.xml editor (add Resource Reference)
Comment 11 Milan Kuchtiak 2006-12-20 07:09:46 UTC
Created attachment 36826 [details]
Struts support (add Action)
Comment 12 Milan Kuchtiak 2006-12-20 07:11:30 UTC
Created attachment 36827 [details]
Struts support (add Forward)
Comment 13 Milan Kuchtiak 2006-12-20 07:11:55 UTC
Created attachment 36828 [details]
web.xml editor (add Resource Reference)
Comment 14 Erno Mononen 2006-12-20 08:50:54 UTC
There are several use cases for this in the visual editors for ejb-jar.xml and 
persistence.xml as well.
Comment 15 Erno Mononen 2006-12-20 08:52:09 UTC
Created attachment 36829 [details]
add cmp relationship
Comment 16 Erno Mononen 2006-12-20 08:57:42 UTC
Created attachment 36830 [details]
add select method
Comment 17 Andrei Badea 2006-12-20 14:52:29 UTC
There are a few use cases in the database support too.
Comment 18 Andrei Badea 2006-12-20 14:53:12 UTC
Created attachment 36846 [details]
create data source
Comment 19 Andrei Badea 2006-12-20 14:55:31 UTC
Created attachment 36847 [details]
create java db database
Comment 20 Martin Adamek 2006-12-20 17:11:55 UTC
Created attachment 36850 [details]
Call EJB dialog validation
Comment 21 Petr Jiricka 2009-07-30 15:45:42 UTC
Is this addressed by issue 148730? Should it be closed as a duplicate?
Comment 22 Stanislav Aubrecht 2012-04-16 13:34:00 UTC

*** This bug has been marked as a duplicate of bug 148730 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo