Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 28561 - [TTV] It's impossible close popup menu by Esc
[TTV] It's impossible close popup menu by Esc
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
Sun Solaris
: P4 (vote)
: TBD
Assigned To: _ tboudreau
issues@platform
: JDK_SPECIFIC, T9Y
Depends on:
Blocks: 33281
  Show dependency treegraph
 
Reported: 2002-11-07 13:50 UTC by Marian Mirilovic
Modified: 2008-12-23 11:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
test case (483 bytes, text/plain)
2002-11-11 12:28 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2002-11-07 13:50:22 UTC
[nb_dev](20021107), [jdk1.4.1](01)

Steps to reproduce:
- run IDE
- open Tools | Options
- right-click on the node
-> popup menu arise
- press Esc
-> popup menu is still visible

If you do the same actions in Explorer, it will be
closed after hitting Esc.
Comment 1 Jiri Rechtacek 2002-11-07 14:12:48 UTC
reassigning to TreeTableView's maintainer.
Comment 2 akemr 2002-11-07 15:30:03 UTC
Look like keybord focus problem:
- works fine on JDK 1.3.1
- doesn't work even in NB 3.4
Comment 3 akemr 2002-11-08 13:31:38 UTC
Fixed in trunk
Comment 4 Jiri Skrivanek 2002-11-11 11:53:04 UTC
Fix causes automated test cannot invoke popup menu. Method
TreeTableView.createPopup(int, int) is called during event processing
but it is empty, so no popup appears.
Comment 5 Jiri Skrivanek 2002-11-11 12:27:11 UTC
Steps to reproduce:
- mount jemmy.jar from
http://jemmy.netbeans.org/servlets/ProjectDownloadList
- mount jelly2-nb.jar from
http://jellytools.netbeans.org/servlets/ProjectDownloadList
- run attached Test28526 by internal executor
- it will open Options but not popup is opened

Also x,y coordinates seems strange when calculated during automated
tests. They are something like [-1103, 91] meanwhile they are [164,
299] when popup is invoked by hand.
Comment 6 Jiri Skrivanek 2002-11-11 12:28:45 UTC
Created attachment 7903 [details]
test case
Comment 7 akemr 2002-11-12 13:32:11 UTC
I don't know, how to avoid above mentioned problem in automated tests
without reopening main problem of this issue.

However, there is suggestion of Alexandre Iline (redirection of all
mouse events to "real" component - to TreeTable, for details see issue
#28562), which will solve test problem on jelly side, so I'm marking
this issue back to fixed.
Comment 8 Marian Mirilovic 2002-11-13 12:57:19 UTC
I am sorry Ales, but it doesn't work in [nb_dev](200211131011),
[jdk1.4.2](b06).

- it's impossible invoke popup menu by Shoft-F10on node in Options
tree table
- it's impossible close menu by Esc(if invoked by mouse right-click)
Comment 9 akemr 2002-11-14 11:28:11 UTC
I commited better fix to trunk:

- Shift-F10 works fine
- Esc works fine on Windows
- Esc doesn't work on Solaris and Linux, if popup was invoked by mouse

So I'm decreasing the priority
Comment 10 Jaromir Uhrik 2003-01-06 13:20:22 UTC
Version changed: 4.0 dev -> S1S 4.2
Comment 11 Jiri Rechtacek 2003-02-27 11:51:51 UTC
Because late phase of nb3.5 cycle, too risky to solve it now. It will
be solved in 4.0.
Comment 12 _ tboudreau 2004-07-25 19:34:32 UTC
Fixed along with the selection bug - requestFocus is no longer called a second time on 
mouse released, which was what was causing the menu to lose focus.
Comment 13 Marian Mirilovic 2004-08-16 08:19:15 UTC
verified in [nb_dev](200408151800)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo