Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 28442 - .ClassNotFoundException: org.netbeans.beaninfo.editors.CompilerTypeEditor
.ClassNotFoundException: org.netbeans.beaninfo.editors.CompilerTypeEditor
Status: VERIFIED DUPLICATE of bug 30998
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
PC Linux
: P3 (vote)
: TBD
Assigned To: David Konecny
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-04 12:30 UTC by dmladek
Modified: 2008-12-23 11:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace CNFE (1.69 KB, text/plain)
2002-11-04 12:32 UTC, dmladek
Details
backuped .nbattrs byt hte ide (1.66 KB, text/plain)
2002-11-13 13:50 UTC, dmladek
Details
.nbattrs in the state I found E. is throwing (1.63 KB, text/plain)
2002-11-13 13:51 UTC, dmladek
Details
.nbattrs after I change compiler setings and revert them back...no more E. (1.66 KB, text/plain)
2002-11-13 13:53 UTC, dmladek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dmladek 2002-11-04 12:30:14 UTC
Product Version       = NetBeans IDE Dev (Build
200211040100)
  IDE Versioning        = IDE/1 spec=3.18
impl=200211040100
  Operating System      = Linux version 2.4.18
running on i386
  Java; VM; Vendor      = 1.4.1_01; Java
HotSpot(TM) Client VM 1.4.1_01-b01; Sun
Microsystems Inc.
  Java Home             =
/usr/java/j2sdk1.4/sun/jdk1.4.1_01/jre
  System Locale; Encod. = cs_CZ; ISO-8859-2
  Home Dir; Current Dir = /home.local/danielm;
/DISKS/storage3/forte/NBdev-last/netbeans/bin
  IDE Install; User Dir =
/home.local/danielm/NBdev-last;
/home.local/danielm/.netbeans/dev
-------------------------------------------------------------------------------

When select a node in Explorer the CNFE is thrown.
see its stackrace
Comment 1 dmladek 2002-11-04 12:32:06 UTC
Created attachment 7848 [details]
stacktrace CNFE
Comment 2 dmladek 2002-11-04 13:00:59 UTC
I'm very, very sorry about entering this issue repeatedly several
times:-((( IZ/PROXY didn't work properly so I've got error after each
submit.

Back to the issue:
------------------
It happend me on a clear build. While I was autoupdating a few modules
I mounted JavaCVS FS.
On that JavaCVS FS it happened me only.
SO what is different from others FSs? I have a java file in it,
with its compiler property sets to: (do not compile)

So it happens me only on nodes/packages above this class in this
hier.structure and also in the file itself.

Comment 3 dmladek 2002-11-04 14:18:53 UTC
another observation:
--------------------
this happen anly if you set such file's compiler properties in
previous build (My previous runned build was WEN Q-build:
2002-10-30-0100)

So, seems to me that it is some incompatibility in storing format
of .nbattrs file

Who is responsible for it?
Comment 4 Jan Lahoda 2002-11-11 14:34:54 UTC
Hi,
   I was able to reproduce this problem using user dir from
200207310100 on 200211060100. I was able to produce this on both
JavaCVS and LocalFilesystem. I am not sure where the problem is. I am
reassigning it to settings for first evaluation.
Comment 5 dmladek 2002-11-13 13:46:19 UTC
It still happens:
I run today's Q-build candidate NB40dev-2002-11-13-011
with clear user dir settings.

So the only thing could persist from prevously usaged builds is 
.nbattrs

I'm gonna attach it in this state as today's build touch it...
(I didn't try or intend to save new settings in it:)
Comment 6 dmladek 2002-11-13 13:50:15 UTC
Created attachment 7930 [details]
backuped .nbattrs byt hte ide
Comment 7 dmladek 2002-11-13 13:51:49 UTC
Created attachment 7931 [details]
.nbattrs in the state I found E. is throwing
Comment 8 dmladek 2002-11-13 13:53:13 UTC
Created attachment 7932 [details]
.nbattrs after I change compiler setings and revert them back...no more E.
Comment 9 David Konecny 2003-02-17 16:22:22 UTC

*** This issue has been marked as a duplicate of 30998 ***
Comment 10 dmladek 2003-07-08 18:44:09 UTC
ok, it is a dup


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo