Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 28422 - Remove dep on openide/compiler from utilities/group
Remove dep on openide/compiler from utilities/group
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Group
3.x
All All
: P2 (vote)
: 3.x
Assigned To: Marian Petras
issues@utilities
:
Depends on:
Blocks: 19443
  Show dependency treegraph
 
Reported: 2002-11-02 21:37 UTC by Jesse Glick
Modified: 2003-12-11 14:27 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2002-11-02 21:37:24 UTC
This dependency should be unnecessary. Suggest:

- Delete GroupShadowCompiler

- Remove CompilerCookie from GroupShadow

- Make GroupShadow implement DataObject.Container

AbstractCompileAction understands DO.C and
traverses it for recursive compilation
automatically. DataShadow already does this.
Comment 1 Jesse Glick 2002-11-22 10:48:10 UTC
*** Issue 28859 has been marked as a duplicate of this issue. ***
Comment 2 Marian Petras 2003-11-11 16:01:09 UTC
OK, I can do it. The only problem I have is as follows:

   How to provide the compile/build actions on nodes representing groups
   if the Group module does not depend on "openide/compiler"?
Comment 3 Jesse Glick 2003-11-11 16:59:20 UTC
Don't provide the actions, I guess. Probably no one needs them there
anyway. You can always use the main menu.
Comment 4 Marian Petras 2003-11-14 13:11:09 UTC
Integrated into the trunk, together with feature #28981 ("allow other
modules to obtain contained links").


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo