Bug 28199 - Reimplement communication between Database Explorer and database
Reimplement communication between Database Explorer and database
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
3.x
All All
: P3 (vote)
: 3.x
Assigned To: Radko Najman
issues@db
: PERFORMANCE
: 34863 (view as bug list)
Depends on:
Blocks: 18229 22802 26106 26612 29866 30319
  Show dependency treegraph
 
Reported: 2002-10-23 10:36 UTC by Radko Najman
Modified: 2003-12-11 14:20 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Radko Najman 2002-10-23 10:36:40 UTC
Communication between Database Explorer and
database (connect/disconnect, retrieve data, etc.)
should run in separate thread to prevent the IDE
from the freeze. The freeze can occur if the
network is overloaded, if the response from the
database server is slow, if the user wants to
retrieve a lot of data, etc.
Comment 1 Radko Najman 2002-10-25 10:35:00 UTC
Not enough resources to do it now. Resoution status changed to LATER.
Comment 2 Radko Najman 2003-02-19 13:29:17 UTC
*** Issue 31136 has been marked as a duplicate of this issue. ***
Comment 3 pzajac 2003-02-25 15:35:04 UTC
This is serious performance problem. 
Comment 4 Radko Najman 2003-03-02 12:55:16 UTC
I agree that it is serious performance problem but the fix requires a
lot of changes in the module. We don't have enough resurces and time
do do it for NB 3.5.
Comment 5 Radko Najman 2003-04-03 09:06:05 UTC
Solved for SQL command execution and disconnect action.
Comment 6 Radko Najman 2003-04-22 14:06:03 UTC
Getting information about the database schema (creating table, column,
etc. nodes) runs in a separate thread now so the IDE is not blocked
anymore. Until the nodes are created, wait node is displayed.
Comment 7 Radko Najman 2003-07-15 13:39:31 UTC
*** Issue 34863 has been marked as a duplicate of this issue. ***
Comment 8 Radko Najman 2003-07-30 11:04:29 UTC
Connect actions reimplemented. Database connection is now established
in non-AWT thread so the IDE is not frozen anymore when connecting to
the database.
Comment 9 Martin Schovanek 2003-10-07 16:34:52 UTC
VERIFIED 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo