Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 28158 - Deadlock on startup.
Deadlock on startup.
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
: RANDOM, THREAD
Depends on:
Blocks: 19443
  Show dependency treegraph
 
Reported: 2002-10-22 00:56 UTC by Michael Ottati
Modified: 2008-12-23 11:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Full stack trace of deadlock (12.64 KB, text/plain)
2002-10-22 00:59 UTC, Michael Ottati
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Ottati 2002-10-22 00:56:23 UTC
This one is very easy to reproduce. I started with todays 
build off of the NetBeans web site.

-----------------------------------------------------------
--------------------
>Log Session: Monday, October 21, 2002 4:36:53 PM PDT
>System Info:
  Product Version       = NetBeans IDE Dev (Build 
200210210100)
  IDE Versioning        = IDE/1 spec=3.15 impl=200210210100
  Operating System      = Windows XP version 5.1 running 
on x86
  Java; VM; Vendor      = 1.4.1; Java HotSpot(TM) Client 
VM 1.4.1-b21; Sun Microsystems Inc.
  Java Home             = C:\java\j2sdk1.4.1\jre
  System Locale; Encod. = en_US; Cp1252

Starting with this kit, I performed the following steps.

1:  Startup the IDE into a new user directory.
2:  Went into tools/options and opened up the Object Types 
tab.
3:  Shutdown the IDE
4:  Startup the IDE into the same userdir from step 1.

When I do this I get the deadlock which I will attach to 
this issue. 

Note that I am running a 2 processor machine. If this can 
not be reproduced on a single processor machine, you might 
want to try it on a 2 processor machine.
Comment 1 Michael Ottati 2002-10-22 00:59:17 UTC
Created attachment 7728 [details]
Full stack trace of deadlock
Comment 2 Marian Mirilovic 2002-10-22 09:07:01 UTC
Radek I am not sure, but it seems like filesystems, feel free to
reassigne.
Comment 3 rmatous 2002-10-22 11:04:09 UTC
In stack trace is no lock, that comes from filesystems. 
Problem seems to be access to NbTopManager.  See main and
FolderChildren_refresher thread and its (newValue call of
org.netbeans.core.ui.ModuleNode.<clinit>)
Comment 4 Jesse Glick 2002-10-23 19:13:15 UTC
Fix should be trivial. I already fixed a very similar bug a few days ago.

Workaround: rm -rfv $userdir/system/Windows/
$userdir/system/Projects/*/system/Windows/

or just don't leave Options dialog open with module node(s) selected
when shutting down.
Comment 5 Jesse Glick 2002-10-23 20:40:25 UTC
Have probable fix, will try to test.
Comment 6 Jesse Glick 2002-10-24 17:15:47 UTC
Hopefully fixed - not sure if the problem was reproducible.

committed   * Up-To-Date  1.4        
core/compiler/src/org/netbeans/core/compiler/CompilationEngineImpl.java
committed   * Up-To-Date  1.71       
core/src/org/netbeans/core/NbPresenter.java
committed   * Up-To-Date  1.67       
core/src/org/netbeans/core/execution/ExecutionEngine.java
committed   * Up-To-Date  1.21       
core/src/org/netbeans/core/ui/ModuleBean.java

The ModuleBean patch was the part actually required for this bug;
other patches are prophylactic.
Comment 7 Marian Mirilovic 2002-10-30 09:39:03 UTC
verified in [nb_dev](20021030)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo