Bug 27976 - OPTIONS dialog does not come back to focus after returning from submenu
OPTIONS dialog does not come back to focus after returning from submenu
Status: CLOSED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
3.x
All All
: P4 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 06:21 UTC by _ gtzabari
Modified: 2008-12-22 15:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2002-10-14 06:21:13 UTC
JDK 1.3.1
dev build 200210030100

1) TOOLS | OPTIONS | EDITING | EDITOR SETTINGS |
JAVA EDITOR | FONT & COLORS | ...

2) Options dialog disappears while the font/color
editor goes into focus

3) Click OK

4) Font/color editor disappears but options dialog
does not come back into focus

NOTE: Under Sun's JDK 1.4.0 (under Windows 2000)
step 4 does not occur so I suspect a JDK-specific
issue is at play here or perhaps there is some
sort of Swing difference between JDK 1.3.1 and JDK
1.4.0.
Comment 1 Marian Mirilovic 2002-11-01 17:07:26 UTC
As you said it works fine on JDK1.4.0, Am I right? So it is JDK specific and we will not fix issues 
related to old JDKs, so close as WONTFIX
Comment 2 _ gtzabari 2002-11-02 02:41:08 UTC
Not exactly:

I neglected to point out that the problem was originally reproduced
under IBM's JDK 1.3.1 (not Sun's). What I said is that this works for
Sun JDK 1.4.x, not IBM JDK where the problem is manifesting itself.
It's quite possible that this issue isn't version specific and will
manifest itself in IBM JDK 1.4.x when it comes out.

If you can repro this with Sun JDK 1.3.x (I don't have access to it
here) we'll assume it is version-specific and reclose the issue;
otherwise I believe it is still a bug to be dealt with.
Comment 3 Marian Mirilovic 2002-11-13 15:30:39 UTC
changed owner Dafe -> Peter Z.
Comment 4 Marian Mirilovic 2002-12-06 17:57:21 UTC
reassigne to Marek, new owner of ui subcomponents
Comment 5 mslama 2003-01-14 13:40:49 UTC
It is not specific to one JDK version. All dialogs have main window as
their owner. (It is to make sure dialog is always in front of main
window.) When dialog is invoked from Options window and Options window
is in separated frame (independent of main window) it cause hiding
Options and putting main window in front of Options window. There was
problem with setting of other owner then main window to modal dialogs
 - their owner can disappear before modal dialog is finished. I am
afraid that with current design when Options is opened as separate
frame it is possible to solve this issue. I will assign it to ui so
they can take it into account when/if they will change current ui design.
Comment 6 jrojcek 2004-06-17 17:08:39 UTC
Marek, is this still an issue? It works for me.
Comment 7 mslama 2004-06-18 09:09:02 UTC
Now Options is dialog with main window as owner not independent
frame/window as before. So it might fix this. I will check.
Comment 8 mslama 2004-06-18 12:59:17 UTC
I tested: NB dev build 200406171800, Linux/RH 9/Gnome and Win XP, JDK
1.4.2_04 and JDK 1.5.0 b56. Still happens. I think problem is that
dialog displayer does not return focus to previously activated window
but to main window. At least now Options dialog stays above main
window as main window is its owner.
Comment 9 Stanislav Aubrecht 2005-01-11 09:21:18 UTC
tested in the latest trunk version and it seems to be working fine
(winxp - jdk 1.4 & 1.5)
Comment 10 Marian Mirilovic 2005-07-14 07:57:25 UTC
verified in NB.dev(200507131800)/closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo