Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 27744 - long running pastes/deletes should display UI progress indicator
long running pastes/deletes should display UI progress indicator
Status: RESOLVED DUPLICATE of bug 55160
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows 3.1/NT
: P4 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
perfuiresp
: PERFORMANCE, UI
Depends on: 27403 50356
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 17:20 UTC by ssffleming
Modified: 2008-12-22 22:36 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ssffleming 2002-10-02 17:20:15 UTC
While this could be considered an enhancement, I am starting this out as a bug (p4)
since the user gets no feedback that the paste is working.

Steps to reproduce:
Create a folder with a 20 java source files each a few K bytes in size.
Copy and paste the folder into another folder

The paste can run for several minutes but gives no progress indicator.
Comment 1 ssffleming 2002-10-02 17:23:53 UTC
Same is true for delete of directory with lots of files in it (via explorer context
menu)
Comment 2 Marian Mirilovic 2002-10-07 11:31:49 UTC
Reassigne to Dafe.
Comment 3 pzajac 2002-10-09 11:06:44 UTC
I changed component to openide. Problem is in Data Systems. Namely  in
DataFolder.Because you perform put action on dataFolder.
Comment 4 Marian Mirilovic 2003-03-13 13:43:49 UTC
Changed owner David S. -> David K.
Comment 5 Jaroslav Tulach 2005-01-28 08:16:47 UTC
Copy&Paste action is implemented in ExplorerUtils.
Comment 6 Jaroslav Tulach 2006-04-21 14:11:48 UTC
I believe this is fixed as part of issue 55160

*** This issue has been marked as a duplicate of 55160 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo