Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 27643 - Check for improper usage of Repository.findResource(..)
Check for improper usage of Repository.findResource(..)
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
All All
: P3 (vote)
: 4.x
Assigned To: Jesse Glick
issues@platform
:
Depends on: 26904 27652 27687
Blocks: 26921
  Show dependency treegraph
 
Reported: 2002-09-27 14:28 UTC by David Strupl
Modified: 2008-12-22 21:40 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Strupl 2002-09-27 14:28:54 UTC
Deprecation of org.openide.filesystems.Repository
- FileObject findResource(String) affects : 
  
org.netbeans.core.projects.XMLSettingsHandler.void
saveOptions()
  
org.netbeans.core.output.OutputTabTerm.OutTermPane.FileObject
getFileObject(String)
  
org.openide.filesystems.AbstractFileObject.Replace.Object
readResolve()
   org.netbeans.core.Main.void startResource(String)
Comment 1 David Strupl 2002-09-27 16:19:07 UTC
I have filed a bug for OutputTabTerm. The other 3 usage are fine
according to pzavadsky. Leaving this open until 26904 is resolved (to
see whether findResource is deprecated or not).
Comment 2 Jesse Glick 2004-03-16 16:59:05 UTC
Done in trunk.
Comment 3 Marian Mirilovic 2005-12-20 15:45:40 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo