Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 27296 - Cannot undo updates from the update center
Cannot undo updates from the update center
Status: REOPENED
Product: platform
Classification: Unclassified
Component: Autoupdate
8.0.2
All All
: P3 with 2 votes (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on: 20323
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 09:33 UTC by Jaromir Uhrik
Modified: 2015-03-09 16:26 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2002-09-13 09:33:10 UTC
This issue is a copy of BQ bug #4746656.

When I get updates from the update center, I cannot undo 
them if they turn out not to work correctly.  As I have 
had updates disable my editor and perform other lesser but 
still antisocial acts, this is a substantial worry for 
me.  No reasonable person who is aware of the threat of an 
irreversible installation introducing a fatal flaw can use 
the update center feature of the product.
Justification:
This is an insurmountable barrier to adoption of a major 
feature in the product.
Comment 1 akemr 2002-09-13 10:24:22 UTC
There is already filed issue #20323 - Allow uninstall module.

This issue can be marked as duplicate of 20323 IMHO, because if you
are able to uninstall new "wrong" version of module, you can install
back the old one (of course you can lost your module settings..).
Comment 2 Jaroslav Tulach 2002-09-17 11:58:21 UTC
The ability to downgrade a module is important for every user of AU.
It is not only about that it is possible, but also that it is
(relatively) easy. 

Would be nice if a user could select a module and choose "Downgrade"
from popup menu and then be presented with all possible older versions
(from local disk or from network, depends). The current version would
be uninstalled and the older one installed seamlessly.

I know there is a problem with settings of downgraded modules, but
this is a problem to be solved by settings api not AU.

I'll be glad if some work could be done on this soon, because this
ability is seen as major architecture flaw.
Comment 3 akemr 2002-09-17 12:15:48 UTC
It depends on #20323: "Allow Uninstall Module"
Comment 4 Marian Mirilovic 2002-12-06 18:50:25 UTC
reassigne to Hrebejk, new owner of autupdate 
Comment 5 Marian Mirilovic 2003-12-01 10:48:49 UTC
reassigne to Jirka - new owner of autoupdate
Comment 6 Jiri Rechtacek 2004-12-08 10:02:26 UTC
Unneeded to track in both issue, closed as duplicate of issue 20323.

*** This issue has been marked as a duplicate of 20323 ***
Comment 7 Marian Mirilovic 2005-07-19 15:21:47 UTC
verified duplicate
Comment 8 sproger1 2014-12-08 17:36:31 UTC
This issue is not a duplicate and was not addressed when issue 20323 was marked as finished. The need for the ability to downgrade a module or undo a recent auto-update still exists.


Jaroslav Tulach 2002-09-17 11:58:21 UTC

The ability to downgrade a module is important for every user of AU.
It is not only about that it is possible, but also that it is
(relatively) easy. 

Would be nice if a user could select a module and choose "Downgrade"
from popup menu and then be presented with all possible older versions
(from local disk or from network, depends). The current version would
be uninstalled and the older one installed seamlessly.

I know there is a problem with settings of downgraded modules, but
this is a problem to be solved by settings api not AU.

I'll be glad if some work could be done on this soon, because this
ability is seen as major architecture flaw.
Comment 9 headbank 2015-03-09 16:26:07 UTC
As long as a bad update can still make the IDE unusable, a rollback function (preferably as insulated from the rest of the codebase as possible, so it can still run under b0rked conditions) is a no-brainer.

In the meantime it looks like I have to get into the habit of backing-up my whole NB install and settings dirs before allowing any updates.  Hope I can find them all :(


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo