Bug 270930 - htmlui cannot be enabled on JDK9
htmlui cannot be enabled on JDK9
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Html4j
Dev
PC Linux
: P1 (vote)
: Dev
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 07:17 UTC by Jaroslav Tulach
Modified: 2017-06-25 01:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2017-06-22 07:17:42 UTC
When I start NetBeans dev build on latest JDK9:

$ ~/bin/jdk1.9.0/bin/java -version
java version "9-ea"
Java(TM) SE Runtime Environment (build 9-ea+174)
Java HotSpot(TM) 64-Bit Server VM (build 9-ea+174, mixed mode)

it reports that it cannot find capability org.openide.modules.jre.JavaFX and as a result it doesn't enable:

Warning - could not install some modules:
org.netbeans.libs.javafx - No module providing the capability org.openide.modules.jre.JavaFX could be found.
org.netbeans.api.htmlui - The module org.netbeans.libs.javafx would also need to be installed.
com.dukescript - The module org.netbeans.api.htmlui would also need to be installed.
com.dukescript - The module org.netbeans.libs.javafx would also need to be installed.

This is probably caused by the "JavaFX support" - http://hg.netbeans.org/releases/file/426cf49d9cea/core.startup/src/org/netbeans/core/startup/CoreBridge.java#l180 
not being ready for JDK9.
Comment 1 Tomas Hurka 2017-06-22 07:32:23 UTC
I guess that capability org.openide.modules.jre.JavaFX can be completely removed, since NetBeans dev. builds are running only on JDK 8 and newer.
Comment 2 Jaroslav Tulach 2017-06-22 09:38:40 UTC
https://hg.netbeans.org/jet-main/rev/8527220caa3b
Comment 3 Jaroslav Tulach 2017-06-22 09:39:55 UTC
Not really. On Solaris and OpenJDK there may be no JavaFX. In such case the capability isn't present and the htmlui & depending modules are properly disabled.
Comment 4 Quality Engineering 2017-06-25 01:47:03 UTC
Integrated into 'main-silver', will be available in build *201706250001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/8527220caa3b
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #270930: Assume JavaFX classes are available on classpath (as they are on JDK8 and JDK9 build 174)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo