Bug 27035 - Can not chose install directory
Can not chose install directory
Status: VERIFIED FIXED
Product: installer
Classification: Unclassified
Component: Code
3.x
PC Windows 3.1/NT
: P1 (vote)
: TBD
Assigned To: Richard Gregor
issues@installer
:
: 27832 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 18:45 UTC by marksarnold
Modified: 2005-07-13 15:11 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marksarnold 2002-09-04 18:45:42 UTC
On some computers I can not chose the installation 
directory where I want to install NetBeans 3.4. They 
already have 3.3.1 and 3.3.2 installed. The installer also 
does not give me the option to import my old settings.
The installer just skips that screen and foes right to the 
proxy settings.
On some other computers it works.
It seems that the ones it works on are Win2k boxes, the 
ones it does not work on are running NT4.

What can I do to get to the installation directory / 
import old settings screen?
Also, if I missed the import of old settings, can I still 
change my project main folder later, so I dont have to 
import all my projects one by one?

Thanks,

MARK
Comment 1 Richard Gregor 2002-09-05 07:43:52 UTC
Is it problem of 3.4 or 3.4dev installer? Did you try the same
installer on Win2k and WinNT4?
If you missed the import of old settings so there should be Import
Settings Wizard invoked during the first startup of IDE.
Comment 2 Jan Chalupa 2002-09-05 12:57:17 UTC
I tried to install NB 3.4 on my NB 4.0 workstation and I did get the
'Installation Directory' dialog and could choose the target location.

I was not given the 'Import Settings' option, although I had NB 3.3.2
properly installed. The 3.4 installed just didn't seem to detect it.

Re:
> If you missed the import of old settings so there
> should be Import Settings Wizard invoked during 
> the first startup of IDE.

Unfortunately not true. The Import Settings Wizard is invoked only
when the userdir doesn't exist or is empty. This is not the case after
you run the 3.4 installer, because it creates the userdir and
pre-populates it with a couple of files. Among others it also creates
the system/dontshowisw. I may not have the best understanding of the
installer functions, but the filename looks pretty self-explanatory.

I can think of two workarounds. Either the user needs to delete the
system folder created by the installer before the first start, or
choose a different userdir location and start the IDE with the
-userdir <newdir> option.
Comment 3 Richard Gregor 2002-09-12 11:03:40 UTC
Fixed.Problem was that on WinNT installer read registry file using UTF-16.
Comment 4 Richard Gregor 2002-10-07 08:41:25 UTC
*** Issue 27832 has been marked as a duplicate of this issue. ***
Comment 5 Michal Mocnak 2005-07-13 15:11:49 UTC
Verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo