Bug 270307 - Regression after recent fixes in fs_server
Regression after recent fixes in fs_server
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
Dev
All All
: P2 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
82patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-05 13:07 UTC by Vladimir Kvashin
Modified: 2017-04-25 14:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2017-04-05 13:07:12 UTC
I see that on spb-avtovo fs_server constantly fails in tests.
Comment 1 Vladimir Kvashin 2017-04-05 19:12:28 UTC
On Solaris, test show lots of orphaned fs_server processes.
There are also some core files, but with stripped binary they don't help a lot.
While trying to reproduce something I found that fs_server, I managed to reproduce the seg fault when exiting:
t@1 (l@1) terminated by signal SEGV (no mapping at the fault address)
0xffff80ffbf584a11: t_splay+0x0011:     movq     0x0000000000000010(%rdx),%rsi
Current function is flush_impl
dbx: warning: can't find file "/home/vkvashin/.netbeans/remote/nyx-intel2.ru.oracle.com/vk-laptop-Linux-x86_64/home/vkvashin/src/netbeans/release82_enum/dlight.remote.impl/tools/fs_server/src/dirtab.c"
dbx: warning: see `help finding-files'
(dbx) where                                                                  
current thread: t@1
  [1] t_splay(), at 0xffff80ffbf584a11 
  [2] t_delete(), at 0xffff80ffbf5848ae 
  [3] realfree(), at 0xffff80ffbf584589 
  [4] cleanfree(), at 0xffff80ffbf584cc2 
  [5] _malloc_unlocked(), at 0xffff80ffbf584068 
  [6] malloc(), at 0xffff80ffbf583f60 
  [7] _findbuf(), at 0xffff80ffbf5b6fed 
  [8] _ndoprnt(), at 0xffff80ffbf5a6be5 
  [9] fprintf(), at 0xffff80ffbf5ac3bc 
=>[10] flush_impl(), line 227 in "dirtab.c"
  [11] dirtab_flush(), line 263 in "dirtab.c"
  [12] shutdown(), line 2073 in "fs_server.c"
  [13] main(argc = 9, argv = 0xffff80ffbfffefe8), line 2116 in "fs_server.c"
Comment 2 Vladimir Kvashin 2017-04-05 20:57:40 UTC
The regression was caused by fixes of static code checks (I would say, rather false positives). Should be fixed by change sets  1197667808c9, e85664e4f8e3 on enum.
Comment 3 Quality Engineering 2017-04-11 01:51:52 UTC
Integrated into 'main-silver', will be available in build *201704110002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/b717216095cb
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixing #270307 - Regression after recent fixes in fs_server
(transplanted from bf7cc1c49f4924cba6f1d16cdcaec7821376c0d0)
Comment 4 ilia 2017-04-13 11:12:38 UTC
https://netbeans.org/bugzilla/show_bug.cgi?id=270307 Changesets:
    http://hg.netbeans.org/releases/rev/bf7cc1c49f49 # fixing #270307 - Regression after recent fixes in fs_server
    http://hg.netbeans.org/releases/rev/1197667808c9 # fixing #270307 - Regression after recent fixes in fs_server --   sources
    http://hg.netbeans.org/releases/rev/e85664e4f8e3 # fixing #270307 - Regression after recent fixes in fs_server --   binaries
Comment 5 Alexander Pepin 2017-04-25 14:33:52 UTC
Do not see such behavior in netbeans-8.2-20170421.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo